WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Interesting Page Cache Error (5 posts)

  1. jelavich
    Member
    Posted 3 years ago #

    We'll have these posts which get a large number of comments, and finally they hit some wall and we get errors like this:

    [Mon Sep 13 05:05:48 2010] [error] [client 64.236.128.62] PHP Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 275282 bytes) in /home/unprofes/www/wp-content/plugins/w3-total-cache/inc/define.php on line 233. That line is checking to see if the content is xml or html.

    That's fine, I can resize my server to get more space and see what is happening. But what's interesting is I could not figure out what caching method was causing this (page cache, database, etc), so I disabled *all* the caching, and I was still getting this message.

    I ended up having to Deactivate the plugin to make the error message go away.

    Two things: 1) This seems to be a slightly excessive way to check for xml vs. http, by reading the entire string. May be better off grabbing the first chunk of data; and 2) Why did I have to deactivate the plugin and not just disable it to make it stop executing part of its code?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did you disable minify? Did you increase PHP memory limit?

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did you disable HTML minify?

  4. jelavich
    Member
    Posted 3 years ago #

    Hi

    Minify is disabled. The only options enabled are "Page Cache", "Object Cache", and "Browser Cache". In fact, when I get this error, I tried to turn off the other three options, but I still received the error. I had to deactivate the plug-in to make that error stop.

    As for increasing php memory, I'm working on this.

    thanks

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Ok.

    2) Why did I have to deactivate the plugin and not just disable it to make it stop executing part of its code?

    Is changed in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic