WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Installation Fatal Error chmod 777 (23 posts)

  1. Vera Schafer
    Member
    Posted 3 years ago #

    I'm trying to install this plugin but I keep getting this error msg:

    Quote
    Plugin could not be activated because it triggered a fatal error.
    /var/www/vhosts/markstultz.com/httpdocs/wp-content/w3tc/dbcache could not be created, please run following command:
    chmod 777 /var/www/vhosts/markstultz.com/httpdocs/wp-content/w3tc
    Unquote

    I downloaded the plugin directly from http://wordpress.org/extend/plugins/w3-total-cache/

    Pls help

  2. leckley
    Member
    Posted 3 years ago #

    Did you change the permissions on the w3tc folder as it is telling you?

  3. Vera Schafer
    Member
    Posted 3 years ago #

    Yes, I did for the w3tc folder the subfolder min + the index.php file.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Can you try the development version?

  5. Vera Schafer
    Member
    Posted 3 years ago #

    Sure! Where from, please?

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

  7. Vera Schafer
    Member
    Posted 3 years ago #

    I tried the development version and got the same error:

    "Plugin could not be activated because it triggered a fatal error.
    /var/www/vhosts/markstultz.com/httpdocs/wp-content/w3tc/dbcache could not be created, please run following command:
    chmod 777 /var/www/vhosts/markstultz.com/httpdocs/wp-content/w3tc"

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Vera Schafer, if you download the latest release you should no longer have an issue.

  9. kernmedia
    Member
    Posted 3 years ago #

    I downloaded the latest release and still have the same problem as Vera. I saw in another thread that one should turn PHP Safe Mode off on one's server, but I can't find this setting on my Hostica hosting account. Did some Google research and it looks like Hostica doesn't offer this setting for editing.

    ???

  10. Vera Schafer
    Member
    Posted 3 years ago #

    I gave up on this plugin and installed WP Super Cache instead.

  11. kernmedia
    Member
    Posted 3 years ago #

    I just tried using WP Super Cache and have the same problem Need to change the folder to 777, do it, and still can't get it to work. It's telling me it's because PHP Safe Mode is enabled. This must be my issue with WP Total Cache, which I'd prefer to use, so I'll wait for my hosting provider to help.

  12. Vera Schafer
    Member
    Posted 3 years ago #

    Since I switched hosting providers, many of my plugin problems were fixed. But I never tried to install W3 Total Cache again, even though my friends liked it better than WP Super Cache ... I wish you luck :-)

  13. kernmedia
    Member
    Posted 3 years ago #

    So I was able to turn PHP Safe Mode off after hearing back from my hosting provider, but still can't get this dang plugin to work. I still get this message:

    Plugin could not be activated because it triggered a fatal error.
    /hsphere/local/home/danielke/sixstringsoul.com/wp-content/w3tc/dbcache could not be created, please run following command:
    chmod 777 /hsphere/local/home/danielke/sixstringsoul.com/wp-content/w3tc
    then
    <RE-ACTIVATE PLUGIN>.

  14. kernmedia
    Member
    Posted 3 years ago #

    Finally got it to work. My hosting company had to change the permissions. For some reason, only they could do it even though it looked like I was doing it.

  15. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @SixStringSoul, glad that's sorted!

  16. Ian Dunn
    Member
    Posted 3 years ago #

    I had this issue on a site that started out somewhere around WP 2.65, so it had a really old wp-config.php. I had to use the wp-config.php from WP 3.1 to get it working. It kept telling me it was a chmod issue even though it wasn't.

  17. Jim Walczak
    Member
    Posted 3 years ago #

    same error message - but when I manually create directory and cmod 777 - then hit the re-activate button - it deletes the folder

    Strange..... suggestions?

    I am running:
    W3 Total Cache 0.9.1.3
    WP 3.1 MU
    APACHE 2.2.3 (Red Hat)
    PHP 5.2.16

  18. Jim Walczak
    Member
    Posted 3 years ago #

    PHP Safe Mode seems to be the culprit - it must be off

  19. hago
    Member
    Posted 2 years ago #

    i found the same issue but found out ! Go FTP with filezilla connect and right clic on folder you want to write go down the list and write 777 until 755 for folders and for files 666 until 644 this is just a restricted access

  20. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Anyone having continued issues here?

  21. Paul G.
    Member
    Posted 2 years ago #

    Hi Fred,

    Yes, I am.

    I have started to take over management of a (dv) (virtual-dedicated) server from media temple.

    I have tried disabling php safe mode as suggested by many here.

    I have chmod777 the wp-content dir.

    I have tried to manually create ..../w3tc/min directories and chmod 777 them all, but no joy - it seems when I attempt to activate the plugin, it removes them anyways.

    I've tried removing the whole plugin directory, uploading a fresh one, and then I get a slightly different error saying:
    <my path>/wp-content/w3tc/dbcache could not be created (it was able to create w3tc/min that time.

    I'm fresh out of ideas, and I hope you might have one or two for me.

    Thanks for a fantastic plugin and all the the work you do to maintain this.

    Cheers for any pointers.
    Paul.

  22. tinystrings
    Member
    Posted 2 years ago #

    I am having the EXACT same issue as Paul G. above, on a dv server from MediaTemple. I'd love to use this plugin but I've tried everything too...

  23. slsdoug
    Member
    Posted 2 years ago #

    Same issue. I do not want to chmod 777 because it is a big security risk.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic