WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Images not replaced in main post content? (2 posts)

  1. benherbert
    Member
    Posted 3 years ago #

    Hi,

    I have tried searching for this but I can't seem to find an answer. I have set-up Amazon Cloudfront/S3 combination on my wordpress site using W3 Total Cache. Everything uploaded fine with the plugin, and I have relatively referenced the files stored on my site for javascript, CSS etc. with no problem whatsoever.

    However, when it comes to using images within the media library in a post, the images are uploaded perfectly to the cloudfront and I can look them up in a browser, but if I use the image url given to me by the media library in the actual post:
    either src= http://www.ymsitename.com/wp-content/uploads/2011/02/image.jpg or just /wp-content/uploads/2011/02/image.jpg
    The images are being served from my main domain instead of the CNAME I set up: http://static.domain.com/wp-content/.../image.jpg

    The only way around it is referencing the image fully (to the static domain) inside the post myself - is that the default behaviour for this? I was under the impression it would search and replace urls based on what is stored on cloudfront - much like it does for style sheets etc.

    If this is the only way of getting it to work I apologise, I just didn't really want to have to use full path names in case I ever decided to come away from using Amazon CDN services.

    Didn't know if I was missing a setting or needed to change something in the media section of wordpress.

    Thanks,
    Ben

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Are you using the latest release of the plugin and still having issues?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic