WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] HTML Minify - Fatal Error In Footer in WP3 (7 posts)

  1. war59312
    Member
    Posted 4 years ago #

    Hi,

    If I enable HTML minify now that I am running WordPress 3, I get this error on the bottom of every page.

    Fatal error: Cannot redeclare class JSMin in /home/war59312/public_html/wp-content/plugins/w3-total-cache/lib/Minify/JSMin.php on line 53

    Though looks like the page is still being minified just fine, so looks like a bug introduced in WP3?

    Thanks,

    Will

    Update: Development Version @ http://wordpress.org/extend/plugins/w3-total-cache/download/ fixes this bug when using WP3. :D

  2. rajupp
    Member
    Posted 4 years ago #

    I still have this problem. I just upgraded to 0.9.0 (latest version) of W3TC and I get exactly the same error when I enable HTML minify. Any idea how to fix this?

  3. Frederick Townes
    Member
    Posted 4 years ago #

    It seems like you have another plugin that uses JSmin running? That's strange. Upgrade to v0.91 first if you can.

  4. rajupp
    Member
    Posted 4 years ago #

    I have upgraded to 0.9.1, but the problem persists.
    Any easy way to find out the "other" plugin using the JSmin function?

  5. Frederick Townes
    Member
    Posted 4 years ago #

    Not from here. Send a bug submission form from the support tab please.

  6. rajupp
    Member
    Posted 4 years ago #

    I have done that. Thanks! will wait for the reply

  7. Frederick Townes
    Member
    Posted 4 years ago #

    @rajupp was running PHP Speedy plugin which is not compatible with W3TC unless you want to live dangerously. :)

Topic Closed

This topic has been closed to new replies.

About this Topic