WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
How to verify Self Hosted CDN is working properly (12 posts)

  1. Dorette
    Member
    Posted 3 years ago #

    I set up my Self Hosted CDN, uploaded all files,
    test server passed.
    No files in queue, everything uploaded great.

    If I run a test on Yslow, I get an Grade F on Use a Content Delivery Network (CDN)
    Page Speed also gives me Serve static content from a cookieless domain

    I can see the files uploaded when I use an ftp program to log into my subdomain which is cdn.mydomain.com

    How do I verify if CDN is working properly

  2. kfawcett
    Member
    Posted 3 years ago #

    To verify if your CDN is working properly, look at the source code of your page. If all the CSS, JS, and image linkes say http://yourcdn.com/thefile instead of http://yourwebsite.com/thefile then your CDN is most likely working properly

    You must setup a cookieless domain in order for the notification in Pagespeed to go away.
    http://www.ravelrumba.com/blog/static-cookieless-domain/
    http://www.riyaz.net/blog/how-to-setup-your-own-cdn-in-30-minutes/technology/890/

    Your CDN will not show up in Yslow unless you add it to Firefox.

    HOW DO I ADD MY CDN HOSTNAME TO YSLOW FOR RULE 2?

    Rule 2 says to use a content delivery network (CDN). The score for this rule is computed by checking the hostname of each component against the list of known CDNs. Unfortunately, the list of "known CDNs" are the ones used by Yahoo!. Most likely these are not relevant to your web site, except for potentially yui.yahooapis.com. If you want an accurate score for your web site, you can add your CDN hostnames to YSlow using Firefox's preferences. Here are the steps to follow:

    Go to about:config in Firefox. You'll see the current list of preferences.

    Right-click in the window and choose New and String to create a new string preference.

    Enter extensions.yslow.cdnHostnames for the preference name.
    For the string value, enter the hostname of your CDN, for example, mycdn.com.

    Restart Firefox.

    Do not use quotes. If you have multiple CDN hostnames, separate them with commas.

    If you specify CDN hostnames in your preferences, they'll be shown under the details for Rule 2 in the Performance view.

  3. Dorette
    Member
    Posted 3 years ago #

    Thanks kfawcett,

    To verify if your CDN is working properly, look at the source code of your page. If all the CSS, JS, and image linkes say http://yourcdn.com/thefile instead of http://yourwebsite.com/thefile then your CDN is most likely working properly

    The image paths are still the old ones, not my cdn.domain.com paths, so I guess they are not working properly

  4. kfawcett
    Member
    Posted 3 years ago #

    Make sure you empty all your caches and refresh your browser at least two times. Then see if you notice anything.

    Is your site live? I can look also to see if it works for me.

  5. Dorette
    Member
    Posted 3 years ago #

    yes, is there an email I can send the link to you

  6. kfawcett
    Member
    Posted 3 years ago #

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @Dorette, has @kfawcett sorted you out?

  8. Dorette
    Member
    Posted 3 years ago #

    Thanks Frederick, we are still working on it

    I just found some things in the unsuccessful file transfers,
    All the errors were source file not found
    Here is the last one not found

    source file
    /home/xxxxxx/public_html/wp-content/w3tc/min/069fde/home.include-body.590815657.js

    remote file
    wp-content/w3tc/min/069fde/home.include-body.590815657.js

    i replaced my site with xxxxxxxx

    does it mean the minify is not working and how do I fix the source and remote paths,

  9. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Try to re-export all the files and make sure that it's working as it should; i.e. you can open the exported files from the CDN in your browser.

  10. Dorette
    Member
    Posted 3 years ago #

    Thanks
    these are my setting for the CDN

    FTP hostname: http://ftp.xxxxxx.com
    FTP username: cdn_username
    FTP password: cdn_password
    FTP path: what should this be (blank or home/xxxxxx/public_html/cdn/
    SSL support:
    Replace site's hostname with: http://www.xxxxxx.com

    WHAT SHOULD THE FTP PATH BE? I have it blank for now, because that is the only way my test passes, if I put in anything the test fails.

    xxxxx is my domain name

  11. robnalexpress
    Member
    Posted 3 years ago #

    @Dorette- Apparently it's Ok to leave the FTP path blank. That's the only way it works for me. If your test passes, you should be OK and able to upload files.

  12. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Yes it's ok, it's the root directory where uploaded files are available via the web.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic