WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] How to Show site modifications with plugin enabled? (7 posts)

  1. bluejpro
    Member
    Posted 2 years ago #

    Hi
    I changed my stylesheet, added a new header image and uploaded them.

    But I can't get them to show up on the live site in my browser.

    I tried clearing all caches and re-exporting all the files.

    Still no change.

    How to view style changes? Is there a way to display the updates without disabling the plugin?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. tgeorge
    Member
    Posted 2 years ago #

    To apply the modifications in the stylesheet, go to the "Minify" tab of W3TC and click on "empty cache". Only the "Minify" is involved with stylesheets.

  3. bluejpro
    Member
    Posted 2 years ago #

    Hi tgeorge

    Thanks for your reply.

    "Empty cache" sounds good. The change I was looking for still doesn't appear in the browser. I am looking for a white background for my project (http://imatchdesigners.com) and I see the old blue one instead.

    SO I tried another approach: Instead of changing the stylesheet to remove the unwanted background image and make the div white (#fff), I just replaced the blue background image with a white one of the same size.

    So I exported all the media files, wp-includes, theme files, minify files and custom files.

    The old bg image is still there.

    I am using the CLoudFlare service. I wonder if that is part of the problem.

    Do you have this problem?

  4. robnalexpress
    Member
    Posted 2 years ago #

    Aside from the header, your site background is white. Did you clear your browser cache?

  5. bluejpro
    Member
    Posted 2 years ago #

    Hi robnalexpress

    Yes, I cleared the browser cache. I even have a 2nd computer I use for checking sites and cleared its cache. Still see the blue bg in the header. The blue bg should be white.

    I put the CLoudFlare service (used with w3 total cache) in development mode. And after this I got a database connection error.

    Does anyone else see "cannot connect to database" error when using the CLoudFlare integration?

    Joanne

  6. robnalexpress
    Member
    Posted 2 years ago #

    (Looks like you got it fixed. Your header now has a white background.)

    I don't use CloudFlare, so I can't help with related issues, but it does look like your issue may be CDN related, in that the 'old' style is still being served from the CDN. Does this happen when you disable W3TC? How about deleting the theme files from the CDN and uploading only the new?

  7. bluejpro
    Member
    Posted 2 years ago #

    Ok, it is working now.

    The way to see changes is to clear all the caches and re-load all the includes, minifies and theme files.

    It also helps to put CloudFlare into development mode.

    The new changes are live. Thanks for all the ideas everybody -- they all helped.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic