WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] How to know it is working or not? (15 posts)

  1. mikanett
    Member
    Posted 4 years ago #

    Hello,
    How do i know W Total Cache is working or not?

    My webserver: Nginx + php-fastcgi + xcache

    I viewed source of my index but i dont see only

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    Served from: fr3x.us @ 2010-08-04 04:09:17 -->

    In my another website which using shared hosting and not using xcache (disk exchanced/disk only), i see that:

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    
    Minified using disk
    Page Caching using disk (enhanced) (cookie is rejected)
    Database Caching using disk
    Object Caching 1325/1339 objects using disk
    
    Served from: minhmeo.info @ 2010-08-04 04:06:02 -->
  2. John Robertson
    Member
    Posted 4 years ago #

    have you enabled the various sections like minify, page cache and so on?

  3. mikanett
    Member
    Posted 4 years ago #

    @braddor: yes, Enabled with Opcode: Xcache

  4. mikanett
    Member
    Posted 4 years ago #

    Here is my testing site: http://fr3x.us/

    Change all option to Disk Exchanced/Disk and nothing new:

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    Served from: fr3x.us @ 2010-08-04 04:09:17 -->
  5. John Robertson
    Member
    Posted 4 years ago #

    A rather dumb question but do you have "Deselect this option to disable all caching functionality." in the first box under General Setting checkmarked?

  6. mikanett
    Member
    Posted 4 years ago #

    Yes, i ticked to this box: Deselect this option to disable all caching functionality.

  7. mikanett
    Member
    Posted 4 years ago #

    When i visit Preview link (http://fr3x.us/?w3tc_preview=1) it's working.

    Dont know why

  8. mikanett
    Member
    Posted 4 years ago #

    just changed all option to opcode Xcache and preview, here is result:

    Warning: xcache_set() [function.xcache-set]: xcache.var_size is either 0 or too small to enable var data caching in /var/www/fr3x.us/wp-content/plugins/w3-total-cache/lib/W3/Cache/Xcache.php  on line 40
  9. Gilligan
    Member
    Posted 4 years ago #

    in /etc/php.d/xcache.ini

    change these to something like:
    xcache.var_size = 32M
    xcache.var_count = 3
    xcache.var_slots = 8K

    save; restart httpd

  10. mikanett
    Member
    Posted 4 years ago #

    @PlayGod: thanks! my site is running fine now!

    my xcache.ini locate at /etc/php5/cgi/conf.d/xcache.ini cos i run Nginx webserver

    do i have to edit php.ini too? because i remember that when i installed xcache, i added this code to bottom of php.ini file:

    [xcache-common]
    extension = xcache.so
    [xcache.admin]
    xcache.admin.user = "mOo"
    ; xcache.admin.pass = md5($your_password)
    xcache.admin.pass = ""
    [xcache]
    ; ini only settings, all the values here is default unless explained
    ; select low level shm/allocator scheme implemenation
    xcache.shm_scheme =        "mmap"
    ; to disable: xcache.size=0
    ; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
    xcache.size  =                64M
    ; set to cpu count (cat /proc/cpuinfo |grep -c processor)
    xcache.count =                 4
    ; just a hash hints, you can always store count(items) > slots
    xcache.slots =                8K
    ; ttl of the cache item, 0=forever
    xcache.ttl   =                 0
    ; interval of gc scanning expired items, 0=no scan, other values is in seconds
    xcache.gc_interval =           0
    ; same as aboves but for variable cache
    xcache.var_size  =            64M
    xcache.var_count =             1
    xcache.var_slots =            8K
    ; default ttl
    xcache.var_ttl   =             0
    xcache.var_maxttl   =          0
    xcache.var_gc_interval =     300
    xcache.test =                Off
    ; N/A for /dev/zero
    xcache.readonly_protection = Off
    ; for *nix, xcache.mmap_path is a file path, not directory.
    ; Use something like "/tmp/xcache" if you want to turn on ReadonlyProtection
    ; 2 group of php won't share the same /tmp/xcache
    ; for win32, xcache.mmap_path=anonymous map name, not file path
    xcache.mmap_path =    "/dev/zero"
    ; leave it blank(disabled) or "/tmp/phpcore/"
    ; make sure it's writable by php (without checking open_basedir)
    xcache.coredump_directory =   ""
    ; per request settings
    xcache.cacher =               On
    xcache.stat   =               Off
    xcache.optimizer =            On
    [xcache.coverager]
    ; per request settings
    ; enable coverage data collecting for xcache.coveragedump_directory and xcache_coverager_start/stop/get/clean() functions (will hurt executing performance)
    xcache.coverager =          Off
    ; ini only settings
    ; make sure it's readable (care open_basedir) by coverage viewer script
    ; requires xcache.coverager=On
    xcache.coveragedump_directory = ""
  11. mikanett
    Member
    Posted 4 years ago #

    anybody help me pls :D

  12. Frederick Townes
    Member
    Posted 4 years ago #

    What exactly is your question? If things are working, you're good to go.

  13. PARoss
    Member
    Posted 3 years ago #

    This is a very strange sentence: "Deselect this option to disable all caching functionality."

    Does it mean "Select this option to enable all caching functionality"?

    Double negatives are generally to be avoided in English.

  14. David Dobo
    Member
    Posted 3 years ago #

    Yes - "This is a very strange sentence: "Deselect this option to disable all caching functionality."
    Does it mean "Select this option to enable all caching functionality"?"
    ???

  15. Frederick Townes
    Member
    Posted 3 years ago #

    This phrasing is changed in the latest releases. Sorry.

Topic Closed

This topic has been closed to new replies.

About this Topic