WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] How to exclude some pages from CDN/Caching (6 posts)

  1. hlwinkler
    Member
    Posted 1 year ago #

    Hello,

    I am using W3TC (happily installed the hotfix this morning) and I have one issue, which is that I want to turn on https on my checkout page but I always get mixed ssl warnings because of images and css/js being loaded with http from MaxCDN. I would actually like to entirely exclude my checkout area from being handled by W3TC at all. Is this possible, or alternately is it at least possible to have certain pages not make use of the CDN? I'd prefer not to also set up my cert with MaxCDN because it adds complexity to my admin task and incurs another yearly cost (and I'm also not sure that the certificate I purchased will work with other domain suffixes).

    Thank you for any assistance!

  2. Raid33
    Member
    Posted 1 year ago #

    I have the same issue. I worked with their support and they recommended using Shared SSL. You basically activate Shared SSL in your pull zone on your MaxCDN account. Then use the shared ssl domain in the W3TC settings: your-site.netdna-ssl.com

    So, it's kind of a workaround. You use the CDN SSL url for everything. That way you can keep everything on your site the same. It's working for us so far.

  3. hlwinkler
    Member
    Posted 1 year ago #

    Ah, unfortunately I can't use shared SSL for the application at hand, but I appreciate the suggestion.

  4. Raid33
    Member
    Posted 1 year ago #

    Which application are you trying to use for checkout?

  5. hlwinkler
    Member
    Posted 1 year ago #

    I use WooCommerce, which requires a dedicated cert in order to do SSL. The second issue is that I've already gotten the dedicated certificate for my server because I didn't realize that the CDN was going to result in an http/https mix, and it isn't a wildcard certificate so I don't think I would be able to use it with MaxCDN. So the best approach at this point looks to me like I should try to find a way to successfully use the certificate I already have and just prevent MaxCDN from being used on the checkout page.

  6. Frederick Townes
    Member
    Posted 1 year ago #

    To disable CDN on a page you need to add define('DONOTCDN', true); on the page request.

    Easiest to add it in the themes function.php

    add_action('init', 'disable_cdn');
    function disable_cdn() {
     if (is_page('yourpage')) {
      define('DONOTCDN', true);
     }
    }

Topic Closed

This topic has been closed to new replies.

About this Topic