WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] How to cache minified pages? (6 posts)

  1. giladpn
    Member
    Posted 3 years ago #

    Hi

    First of all thanks for the excellent W3TC plugin.

    I am using Google PageSpeed to optimize. PageSpeed tells me that the minified include files (see their URLs below) do not have expiration specified. These files are created by W3TC.

    Is there a reason for this? Is there any way to specifically specify an expiration for these two files, without interfering with any other files?

    http://www.porticor.com/wp-content/w3tc/min/b82dd9/default.include.1710310803.css (expiration not specified)

    http://www.porticor.com/wp-content/w3tc/min/b82dd9/default.include.1952147925.js (expiration not specified)

    Thanks!

  2. Klark0
    Member
    Posted 3 years ago #

    Enable Browser Cache in W3T and check it's settings page. Make your htaccess writable before you do.

  3. giladpn
    Member
    Posted 3 years ago #

    I did that. I enabled "Set expires header" for CSS and JS files in the W3TC settings.

    This however does not change the result.

    Any more ideas?

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Try to set all browser cache settings for CSS & JS files and see if that satisfies the test.

  5. giladpn
    Member
    Posted 3 years ago #

    Thanks it worked. I set also "Set cache control header" (in addition to "Set expires header") and this does work.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Great.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic