WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Homepage not updating (7 posts)

  1. irishdude
    Member
    Posted 3 years ago #

    I have W3 Total Cache setup to clear the cache every 10 minutes. My website is serving a 5 day old cache file for the homepage when logged out. If I browse to an internal page and then click on the homepage again it serves the latest cached file which is very weird. This happens on computers that have never visited the website before and are not logged in.

    Any ideas why this would be happening?

    I'm running the latest wordpress and W3 Total Cache.

  2. microkid
    Member
    Posted 3 years ago #

    I am also having problems with the cache not being refreshed for days. It seems "garbage collection" doesn't work as expected and browser caching is very aggressive as well.

    Are there any known issues/solutions with this or known conflicts?

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    If you don't have traffic to lots of other pages in your site it's possible that garbage collection will occur. I'm adding this to the FAQ so that users can manually configure cron.

  4. microkid
    Member
    Posted 3 years ago #

    Hi Frederick. I understand now what is causing this. Do you have any suggestions on how to solve this with a cronjob? I guess calling anything that starts up WordPress in full effect should solve this right?

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    If your server access or hosting control panel supports it you can actually load the wp-cron.php file at some interval (every 10 minutes) and that will keep WordPress running well. Or you can simply lower the expires time on the browser cache settings tab and then WP will behave better for you.

  6. natebeaty
    Member
    Posted 3 years ago #

    I am having a similar problem with /page/2/ and /page/3/ etc not updating their page cache files. The homepage updates every minute just fine.

    I have followed your advice to set a low expires time on HTML (currently at 180s). Garbage collection is set to run every 600s, and I even have the Cache Preload set to run every 3600s, referencing our sitemap.xml (which doesn't have /page/2/ etc listed of course). Nothing seems to work.

    I've set a cronjob to run wp-cron every 15min (which was happening before even installing W3 Total Cache).

    Is there anything else I can do to insure /page/2/ and /page/3/ update frequently? Or something specific to look for in determining why /page/2/ isn't updating in pgcache?

    Ideally the homepage and all /page/ files would update automatically every time a new post is entered. My client currently posts 10-20 times a day, and the /page/2/ cache doesn't update until I manually force it to.

  7. natebeaty
    Member
    Posted 3 years ago #

    For now I've got a cronjob running rm -rf .../wp-content/w3tc/pgcache/page/* every 15 minutes. Not terribly elegant, but it's doing the trick for now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic