WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] High number of S3 PUT requests (5 posts)

  1. Scott Bressler
    Member
    Posted 2 years ago #

    Hi,

    I notice from my AWS usage numbers that there are about 6MB of PUT requests from W3 Total Cache every hour, which is generating some many hundreds of thousands of PUT requests each month for a low-traffic site. I imagine this is the plugin uploading all of my wp-content and wp-includes files every hour. When I look at the management console, all of the files do indeed have a timestamp of the last hour.

    I notice that the "Auto upload interval" is set to 1 hour (3600), but it seems that uploads should only occur if files change. I'd be happy to increase that number, but I'm curious why the upload is happening at all when nothing has changed.

    Thoughts?

    Thanks,
    Scott

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. jivyb
    Member
    Posted 2 years ago #

    I've been having problems with my site triggering memory limits at dreamhost shared...thinking this might have something to do with it. I'm interested in the answer.

  3. Scott Bressler
    Member
    Posted 2 years ago #

    Any thoughts from anyone, particularly Frederick?

  4. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Memory limit issues can be addressed with .htaccess directives.

    As for lots of PUT requests is "Force over-writing of existing files" enabled?

  5. Scott Bressler
    Member
    Posted 2 years ago #

    It was enabled. Just unchecked it and a few hours later, it seems no unnecessary uploads have occurred. Assuming it's not checked by default, I must have checked it a while ago when uploads/overwrites weren't working. Perhaps it's worth somehow verifying with the user that they intend to leave it checked for months at a time.

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic