WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Help Wizzard (21 posts)

  1. djmorrisinc
    Member
    Posted 4 years ago #

    When I clicked on the 'help wizzard' I got an error message that said...

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4180

    How do I fix this?

  2. DivaVocals
    Member
    Posted 4 years ago #

    I got the exact same error tonight..

  3. DivaVocals
    Member
    Posted 4 years ago #

    Still getting this error.. Is there no solution for it??

  4. Ryan Cowles
    Member
    Posted 4 years ago #

    I submitted a Bug Report with the same error. I believe the error started after an upgrade, so maybe there is a small bug within the new version, or perhaps it clashes with another plugin.

  5. invi2003
    Member
    Posted 4 years ago #

    It would help to know which versions you guys are running. Thanks

  6. djmorrisinc
    Member
    Posted 4 years ago #

    I'm running 0.9.1 and WP 3.1....I submitted a bug report that Fred responded to and said he would fix in the next release :).

  7. Ryan Cowles
    Member
    Posted 3 years ago #

    I am running the same. Thank you for the update dj!

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Can someone please confirm that this happens in the latest release?

  9. djmorrisinc
    Member
    Posted 3 years ago #

    Yes, it does happen in the latest release....

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/jupite11/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4180

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/jupite11/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4197

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/jupite11/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4197

  10. DivaVocals
    Member
    Posted 3 years ago #

    @Frederick,

    I am using ver 0.9.1.1. I just reactivated the plugin this morning and can happily report that the error no longer occurs for me..

    More importantly my CSS and JS files are not finally minified correctly..

    So thanks sooooo much for all your hard work on this plugin!!

  11. DivaVocals
    Member
    Posted 3 years ago #

    WHOOPS!!! BIG CORRECTION needed for my last post.. Sorry for the typo..

    More importantly my CSS and JS files are NOW finally minified correctly..

    So thanks sooooo much for all your hard work on this plugin!!

  12. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @djmorrisinc, fixed the development version.

  13. bekar09
    Member
    Posted 3 years ago #

    @Frederick Townes, can we expect an update for this fix soon?

  14. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The fix is available in the development version of the plugin.

  15. pastorbobsteele
    Member
    Posted 3 years ago #

    Hello.

    I am getting the same error as djmorrisinc.

    Where can we find the development version of the plugin?

    Thank you.
    Bob

  16. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

  17. leandrocc
    Member
    Posted 3 years ago #

    I have the same error... is the development version safe enough to a production site?

    And what should be the procedure?
    Deactivate and delete current version, upload, activate and config new version? Or can I just overwrite it?

    BTW, I'm running WP 3.0.1 and latest version of the plugin.

  18. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    If it wasn't I wouldn't recommend it. Deactivate, delete, upload, activate.

  19. leandrocc
    Member
    Posted 3 years ago #

    Thanks Frederick,

    I updated the plugin and everything works just fine. I'll give it some days to confirm it's faster and using less resources, but so far so good.

  20. bt-chadski
    Member
    Posted 3 years ago #

    Frederick,

    I was experiencing the same issues as leandrocc and after "Deactivate, delete, upload, activate" experiencing more issues:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/user/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4180

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/user/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4180

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/user/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4180

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/user/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php on line 4197

    On top of it I get "Recently an error occurred while creating the CSS / JS minify cache: Some files were unavailable, please check your settings to ensure your site is working as intended"

    Thoughts?

  21. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Those warnings are gone in 0.9.1.2, if you still saw them after you upgraded, you will need to export your settings file, delete the plugin and reinstall.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic