WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Having trouble disabling browser caching for certain pages. (3 posts)

  1. Craig Chamberlin
    Member
    Posted 1 year ago #

    I'm sure this is a simple fix, but here is my problem:

    I recently installed buddy press so the following pages need to be prevented from caching.

    /forums/
    /groups/
    /members/
    /activity/
    /blogs/
    /messages/
    /register/
    /activate/

    So as a result, I added the following to the 'Never Cache' section for Page Cachinge:

    /forums/*
    /groups/*
    /members/*
    /activity/*
    /blogs/*
    /messages/*
    /register/*
    /activate/*

    This all worked great! However, now I am running into a browser caching issue. Even though the server itself is not caching the pages it appears the browser is caching them locally.

    Can I make exceptions for browser caching or do I need to disable it?

    As of right now, my potential logged out community members will need to clear their local cache to see the community pages update.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Craig Chamberlin
    Member
    Posted 1 year ago #

    Okay, it appears it's associated with database and / or object caching. Now I just need to find out what exceptions I need for buddypress.

  3. Craig Chamberlin
    Member
    Posted 1 year ago #

    Nevermind, it is still doing it on Firefox for sure. This occurs no matter what if browser cache is enabled. I really need to find a way to disassociate all subdirectories with buddypress in browser caching.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic