WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] Fatal error after emptying (opcode) cache (17 posts)

  1. Taragon
    Member
    Posted 4 years ago #

    Hello,

    After having set both Page Caching and Minify to Opcode: XCache (somehow my host doesn't support APC) I keep getting this error after emptying all or opcode only cache:
    Fatal error: xcache_clear_cache() [<a href='function.xcache-clear-cache'>function.xcache-clear-cache</a>]: unexpect 8 bytes of xcache.admin.pass, expected 32 bytes, the password after md5() in /home/design24/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache/Xcache.php on line 89
    Does someone might know what I might be overlooking here?

    Best regards,

    Cor

  2. Taragon
    Member
    Posted 4 years ago #

    Just set

    Minified using disk
    Page Caching using disk (enhanced)
    Database Caching using xcache

    and things are working now brilliantly well actually.

  3. Frederick Townes
    Member
    Posted 4 years ago #

    Fatal error: xcache_clear_cache() [<a href='function.xcache-clear-cache'>function.xcache-clear-cache</a>]: unexpect 8 bytes of xcache.admin.pass, expected 32 bytes, the password after md5() in /home/design24/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache/Xcache.php on line 89

    Wrong xcache.ini setting: xcache.admin.pass should be md5 hash of password and 32 symbols length.

  4. Taragon
    Member
    Posted 4 years ago #

    Hi Frederick, I now realize this as well. Could you tell how to set/reset this?

    ;xcache.admin.user = "admin"
    ;xcache.admin.pass	= ""
    ;xcache.admin.enable_auth = On
    xcache.test = Off
    xcache.coredump_directory = ""
  5. Taragon
    Member
    Posted 4 years ago #

    Hi Frederick,

    With some pain and effort it's working like a charm.

    Again, much appreciated.

  6. Frederick Townes
    Member
    Posted 4 years ago #

    Great.

  7. Galerio
    Member
    Posted 4 years ago #

    @Taragon
    can you also explain us how have you resolved your issue?

    I have a similar issue too, but I don't know what to do.

    My error is:
    Fatal error: xcache_clear_cache() [<a href='function.xcache-clear-cache'>function.xcache-clear-cache</a>]: xcache.admin.user and xcache.admin.pass is required in /home/siti/www.1e2.it/1e2.it/htdocs/wp-content/plugins/w3-total-cache/lib/W3/Cache/Xcache.php on line 89

    and my xcache.ini file is:

    # configuration for php Xcache module
    
    [xcache-common]
    ;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
    zend_extension = /usr/lib/php5/20060613+lfs/xcache.so
    
    [xcache.admin]
    xcache.admin.enable_auth = On
    # Configure this to use admin pages
    ; xcache.admin.user = "mOo"
    ; xcache.admin.pass = md5($your_password)
    ; xcache.admin.pass = ""
    
    [xcache]
    ; ini only settings, all the values here is default unless explained
    
    ; select low level shm/allocator scheme implemenation
    xcache.shm_scheme =        "mmap"
    ; to disable: xcache.size=0
    ; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
    xcache.size  =                16M
    ; set to cpu count (cat /proc/cpuinfo |grep -c processor)
    xcache.count =                 1
    ; just a hash hints, you can always store count(items) > slots
    xcache.slots =                8K
    ; ttl of the cache item, 0=forever
    xcache.ttl   =                 0
    ; interval of gc scanning expired items, 0=no scan, other values is in seconds
    xcache.gc_interval =           0
    
    ; same as aboves but for variable cache
    xcache.var_size  =            0M
    xcache.var_count =             1
    xcache.var_slots =            8K
    ; default ttl
    xcache.var_ttl   =             0
    xcache.var_maxttl   =          0
    xcache.var_gc_interval =     300
    
    xcache.test =                Off
    ; N/A for /dev/zero
    xcache.readonly_protection = Off
    ; for *nix, xcache.mmap_path is a file path, not directory.
    ; Use something like "/tmp/xcache" if you want to turn on ReadonlyProtection
    ; 2 group of php won't share the same /tmp/xcache
    ; for win32, xcache.mmap_path=anonymous map name, not file path
    xcache.mmap_path =    "/dev/zero"
    
    ; leave it blank(disabled) or "/tmp/phpcore/"
    ; make sure it's writable by php (without checking open_basedir)
    xcache.coredump_directory =   ""
    
    ; per request settings
    xcache.cacher =               On
    xcache.stat   =              Off
    xcache.optimizer =           Off
    
    [xcache.coverager]
    ; per request settings
    ; enable coverage data collecting for xcache.coveragedump_directory and xcache_coverager_start/stop/get/clean() functions (will hurt executing performance)
    xcache.coverager =          Off
    
    ; ini only settings
    ; make sure it's readable (care open_basedir) by coverage viewer script
    ; requires xcache.coverager=On
    xcache.coveragedump_directory = ""
  8. Galerio
    Member
    Posted 4 years ago #

    Here is the solution:
    uncomment the line with ;xcache.admin.enable_auth = On (that is remove the ; at the beginning) and change the option to Off. The result must be:
    xcache.admin.enable_auth = Off

    And now it works!

  9. Frederick Townes
    Member
    Posted 4 years ago #

    Thanks.

  10. mikanett
    Member
    Posted 4 years ago #

    @galerio: i tried your solution but it still error.

    ;xcache.admin.user = "admin"
    ;xcache.admin.pass      = ""
    xcache.admin.enable_auth = Off
    xcache.test = Off
    xcache.coredump_directory = ""
  11. mikanett
    Member
    Posted 4 years ago #

    I tried again

    nano /etc/php5/cgi/conf.d/xcache.ini

    xcache.admin.enable_auth = Off

    Not found error, but when i add new post, it cannt save draft (always: Saving Draft… )

  12. Frederick Townes
    Member
    Posted 3 years ago #

    Sorry, for my part, I cannot guess other solutions without investigating on your server. Anyone else?

  13. crypted
    Member
    Posted 3 years ago #

    This is probably silly, but when you edited the xcache.ini and saved it with the auth to OFF setting... did you restart apache?
    "/etc/init.d/apache2 restart"

    I had the same problem you were having. So, I edited the xcache.ini and restarted the httpd server, no problems working swell.

  14. Frederick Townes
    Member
    Posted 3 years ago #

    @mikanett?

  15. jgrand_idea
    Member
    Posted 3 years ago #

    I also get the same error.

    Fatal error: xcache_clear_cache() [function.xcache-clear-cache]: xcache.admin.user and xcache.admin.pass is required in ...line 89.

    While the site is working, I cannot add/edit post and do a whole bunch of stuff.

    Too bad I do not know php or how to edit the xcache.ini. I paid host to install and make the modifications but I don't know why they can't modify the portion where you could turn the admin.user off.

    What I did was to comment out the function up to line 89. And the errors all went away.

    Question is: Is it ok to comment out that particular function? What would be the subsequent effect? Anyone knows what that particular function is for? The php line goes

    /**
         * Flushes all data
         *
         * @return boolean
         */
        /**function flush()
        {
            xcache_clear_cache(XC_TYPE_VAR, 0);
    
            return true;
        }*/

    I have the above disabled, what would happen?

  16. jgrand_idea
    Member
    Posted 3 years ago #

    my host, probably exasperated over my lack of knowledge installed xcache.ini in w3tc directory. I tried editing files to no avail. The same error appears when I publish or update blogs or empty caches. Although, changes are nonetheless made in updated blogs even when the error appears. Anyone having the same problem?

  17. Frederick Townes
    Member
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic