WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] External file import is disabled (8 posts)

  1. wordpressfantoday
    Member
    Posted 3 years ago #

    On my blog, I have lots of Flickr images embedded in my posts. Each of the Flickr images link to their respective Flickr pages.

    When I try to run the Media Library Import, I get the following:

    http://farm5.static.flickr.com/aaaa/bbbbb.jpg External file import is disabled
    http://www.flickr.com/photos/aaaaa/ddddd/ File type rejected

    The first is obviously the image file that I embedded. The 2nd is the link to the Flickr page of the first.

    In the CDN -> File Types to import, I have *.jpg;*.png;*.gif;*.avi;*.wmv;*.mpg;*.wav;*.mp3;*.txt;*.rtf;*.doc;*.xls;*.rar;*.zip;*.tar;*.gz;*.exe.

    Is there an option I forgot to turn on?

    BTW, superb plugin and keep up the great job!

  2. wordpressfantoday
    Member
    Posted 3 years ago #

    Just to provide more info, this is running on a VPS, with FTP turned off.

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    On the content delivery network (CDN) settings tab, you need to select "Import external media library attachments" and save your settings before running the import tool.

  4. thrivingnow
    Member
    Posted 3 years ago #

    On the content delivery network (CDN) settings tab, you need to select "Import external media library attachments" and save your settings before running the import tool.

    I have the same error. And I have searched and searched the current interface for a select item on the Content Delivery Network (CDN) settings tab called "Import external media library attachments".

    The general tab there has these options, all checked:
    Host wp-includes/ files
    Host theme files
    Host minified CSS and JS files
    Host custom files
    (Save Changes Button)

    Then comes Configuration and Advanced. Can't find it there, either.

    OKAY! Tried something. Disabled the MaxCDN and switched back to self-hosted, and viola! Two options appear:

    Force over-writing of existing files
    Import external media library attachments

    I turned on the Import external media library attachments, switched back to the CDN, and NO! Unable to download file...

    http://www.animaltalk.us/images/uploads/whats-that.jpg
    For example, this loads fine with http: but the import into media library fails with Unable to download file.

    Anyway, feels like a big or something I don't understand. Thanks for your help!

    Rick

  5. thrivingnow
    Member
    Posted 3 years ago #

    Want to add: My WP directory is /wp but the site address is / with the appropriate handling in the index.php and .htaccess

    Still cannot figure out how to handle the media import, though. Would be great to do so, since the CDN is working GREAT (MaxCDN) on everything except those files in /images/uploads

    (I did try to add /images/* and/or /images/uploads/* to the list that would be cached on the CDN, but it didn't work. Those images after clearing all the caches in WP and on MaxCDN were still www. addresses not cdn (whereas theme files, etc., did show the url change).

    Rick

  6. thrivingnow
    Member
    Posted 3 years ago #

    I've tried it every which way to Sunday, and it still says Unable to download file to images that if I grab the URL and paste it into a browser works FINE...

  7. wordpressfantoday
    Member
    Posted 3 years ago #

    Frederick,

    I'm getting the External file import is disabled and File type rejected errors when I click on Start in the popup "Import external media library attachments" window. Should I be doing something before that to set it up for the import? Otherwise, I'm not sure what I'm doing wrong.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Please submit bug submission forms from the support tab of the plugin you two.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic