WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Error Notification on total cache running on IIS server (13 posts)

  1. j4ydman
    Member
    Posted 4 years ago #

    Hi,

    Ive got a wordpress installation using total cache on a Windows Server to start with. My dev server is on a Linux on and the plugin runs like a dream. On the staging server (windows), inside wordpress admin/totalcache. Its always prompting these errors on top of the page:

    You've selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please run chmod 777 C:/inetpub/wwwroot/mysite.com/.htaccess,

    You've selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please run chmod 777 C:\inetpub\wwwroot\mysite.com/wp-content/w3tc/pgcache/.htaccess

    I am in the dark when it comes to IIS, is there anyone out there who could help me solve this problem. Its just my clients server is windows so i have to deal with this.

    Your replies will be highly appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Do you know how to change file permissions for directories/files on windows? The instructions provided are for linux-based hosting.

  3. j4ydman
    Member
    Posted 4 years ago #

    Hi there, is there any guides for windows that i can follow? Really struggling here. thanks

  4. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Sorry, no there aren't..... yet.

  5. seriousthings
    Member
    Posted 3 years ago #

    ya, I'm in the same boat. On a windows server (shared server on Godaddy).

    You've selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please create an empty file in D:/.htaccess and run chmod 777 D:/.htaccess

    and I'm a n00b. Created a .htaccess file in the root directory of the blog, no go. I don't even think .htaccess is a file for a windows server, haha. The file appears to have the correct permissions. Tried pasting in the suggested code for manual configuration....ya, you know where that got me, haha.

    Any guidance out there yet...or an ETA? Thanks for your involvement w/ the customers Frederick.. It's people like you who I see answering questions for potential users that I want to donate to. So hey, someone sees it.

    God bless

  6. efikim
    Member
    Posted 3 years ago #

    If its a Windows server using IIS rather than Apache (and I expect most Windows servers will be) then it doesn't use a .htaccess file for configuration. I think W3TC requires Apache.
    There is a third party addon available for IIS ( http://www.isapirewrite.com/ ) but would need to have been purchased and installed by the hosting company.

  7. seriousthings
    Member
    Posted 3 years ago #

    ya, it's using IIS.

    Any ideas on complications that can arise if I move WP from a windows to a linux server? I'm sure it isn't as simple as a backup and reloading it on the new server. That would be amazing if it was..

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    For now those on windows should use disk basic for page caching.

    You can move WP to Linux without issue.

  9. seriousthings
    Member
    Posted 3 years ago #

    Thanks for chiming in Frederick.. Good timing, as I'm currently working on some difficulties with the FTP for CDN after a server move.

    I ended up moving to a linux shared server and got w3tc setup. CDN/FTP was working fine, no challenges. The new linux server from godaddy was doggin' bad, so I moved again to the grid linux at godaddy. After the move to the grid server, the FTP ceased to work.

    My original settings were working just fine... Once the server was moved, I popped in the new IP address.. and I get Error: Unable to connect to <ip addy>. I can't figure this one out cuz I can ftp into the site just fine from filezilla and other clients.

    Any suggestions on where to look?

  10. seriousthings
    Member
    Posted 3 years ago #

  11. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I think it's best to ask godaddy, why your site cannot create an FTP session. At this point I don't know their network topology and what the challenges are.

  12. seriousthings
    Member
    Posted 3 years ago #

    ya, I tried godaddy... FTP is working just fine. The move from the linux shared hosting to the linux grid only changed my IP.. they said the servers are otherwise identical outside of the # of servers and how loads are handled.

    In the compatibility check it says:
    FTP functions: OK

    Something didn't get moved correctly or the old settings are still stuck in there some where.. No clue. FTP is working from cmd prompt and filezilla.. so it seems to be specific to w3tc

  13. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I can only suggest submitting a bug submission form then in order to sort this issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic