WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Error message, plugin can not be activated (4 posts)

  1. MrCerbuly
    Member
    Posted 2 years ago #

    Hi to all

    I've just downloaded w3 total cache plugin to speed up my website http://www.constructii24.ro
    Unfortunatly I received on wordpress a error message.
    /home/rconst25/public_html/wp-config.php could not be written, please edit config and add:
    define('WP_CACHE', true); before require_once(ABSPATH . 'wp-settings.php');

    Sorry, I am NOT a TechFreak and so I not really understand how to fix the issue??? Maybe anybody find time to explain me what to do? Please explain in words for a child in "kindergarten" age........

    thanxs a lot
    MrCerbuly

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. tgeorge
    Member
    Posted 2 years ago #

    1. Open your FTP program and connect to your site.
    2. Browse to the /public_html/ folder.
    3. Edit the wp-config.php file (it's a text file).
    4. Find the line require_once(ABSPATH . 'wp-settings.php'); (it's at the end).
    5. Insert a new line before the previous line and paste define('WP_CACHE', true);

  3. robnalexpress
    Member
    Posted 2 years ago #

    Not everyone knows what an FTP program is or even has one installed. If that's the case, you can also use your site's control panel (not WordPress Admin, but Cpanel). Locate the wp-config.php file, right click and select "code edit", make the changes and click save.

    I'm not sure why the message is telling you to put that line in that specific location in the file. FWIW, in mine it's at the top. Here's the first few lines of my wp-config.php file:

    <?php
    
    /** Enable W3 Total Cache */
    define('WP_CACHE', true); // Added by W3 Total Cache
    
    /**
     * The base configurations of the WordPress.

    If you're not experienced/comfortable editing code, make a copy of the file first, just in case you make a mistake.

  4. MrCerbuly
    Member
    Posted 2 years ago #

    Thank you so much for help

    I made insert a new line before the previous line and paste define('WP_CACHE', true); and it works. The plugin is activated

    Thanks
    MrCerbuly

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic