WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Error: Comments are closed (7 posts)

  1. Dennis8
    Member
    Posted 3 years ago #

    Ever since I'm using the newest version of W3 cache I havent been getting much comments anymore. Now someone just emailed me saying that he couldnt comment on any of the posts as the message "Comments are closed" came up. I have not closed comments though (I just checked) and the weird thing is that Im not using any comments plugin, only the wordpress internal program. Could the inline JS minification or line break removal under html minify settings be the problem? Or even the gzipping? As for JS minify settings I have disabled these for now, although like I said Im not using a comment plugin so this shouldn't be the problem.

    Also, there's another thing Im kinda concerned about:
    When you check the following webpagetest results there are red markings regarding cookies, giving me a fail score.
    http://www.webpagetest.org/result/100907_4DA5/1/performance_optimization/
    From what I gather this concerns images, css and the like. But I dont understand what type of cookies they are talking about here. You can find a detailed listing of these "failed cookies" when you scroll down to "proper cookie usage". Im pretty sure Ive been getting this only since W3 but the weird thing is that on some page tests it says failed cookies and on others I get a 100% score. So do I need to be worried about this?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    When you disable any of the caching types comments work normally?

    Cookies are set by services like google analytics, so it's suggested to host CSS/JS/images etc on a domain that does not have cookies for better performance.

  3. Dennis8
    Member
    Posted 3 years ago #

    When you disable any of the caching types comments work normally?

    I just went through all the options and disabling them one by one to see if anyone of them would make comments work again. And lo and behold, when I disable "Object caching" the comments go through again without the error page "Comments are closed". So why is that? Is this normal? Remember, my comments are from the internal WP platform. Even though comments are working again I notice that it takes quite a while for them to go through, the loading times are sometimes beyond 10 secs. So something still seems wrong?

    Cookies are set by services like google analytics, so it's suggested to host CSS/JS/images etc on a domain that does not have cookies for better performance.

    I dont have google analytics installed on my site. Either way, from what it sounds like its not like some cookies vital to the site arent working, right?

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Can you submit a bug submission form from the support tab of the plugin please?

  5. @Dennis8

    I just checked your site and noticed a few things. On a single post page the server is returning a status 200 OK for http://www.usbmemorysticks.net/wp-content/w3tc/min/725294/single.include.1437250770.js but the file only contains

    Failed to load source for: http://www.usbmemorysticks.net/wp-content/w3tc/min/725294/single.include.1437250770.js

    You might need to clear your page cache and minify cache to fix this.

    The comment form shows and I was able to submit a comment but not sure if it went through.

    Also the js is the first file and its before the css which is causing a 3.8 second block before anything else can get downloaded. It's not as bad on the home page but the js is first on every page.

    Change the embed location to non blocking <head> to fix that issue.

    The cookies are the normal cookies WordPress adds to all requests. It's not a big deal but if you want to get rid of cookies on your static content you need to set up subdomain to serv static content. You can use W3 Total's self hosted CDN features to serve the content. You will have to set up the subdomain in cpanel then enter the cname into W3 along with your ftp information and follow the instructions.

    To remove the cookies from the subdomain add this line to your config.php: define('COOKIE_DOMAIN', 'www.usbmemorysticks.net');

    AskApache has a good article on setting up cookieless sub domains with WordPress

  6. Dennis8
    Member
    Posted 3 years ago #

    I just checked your site and noticed a few things. On a single post page the server is returning a status 200 OK for http://www.usbmemorysticks.net/wp-content/w3tc/min/725294/single.include.1437250770.js but the file only contains

    Failed to load source for: http://www.usbmemorysticks.net/wp-content/w3tc/min/725294/single.include.1437250770.js

    What would cause this?

    You might need to clear your page cache and minify cache to fix this.

    I did and when I follow your links to the js file, it doesnt give that failed message anymore.

    The comment form shows and I was able to submit a comment but not sure if it went through.

    Thanks for testing it out. Do you remember how long it took for the pate to reload after you submitted the comment? Your comment did go through, but you landed in the spam folder. I "unspammed" it and posted a reply. :)

    Also the js is the first file and its before the css which is causing a 3.8 second block before anything else can get downloaded. It's not as bad on the home page but the js is first on every page.

    Change the embed location to non blocking <head> to fix that issue.

    Ok, I changed all to "non blocking head" but the loading time still seems to be the same (for commenting as well as just the page load). When I look up the page source the js still seems to be before the CSS. Is that because I have js to "Combine only before </body>"? Or could it be because I have CSS not minified? I can't because CSS minification messes up my theme.

    The cookies are the normal cookies WordPress adds to all requests. It's not a big deal but if you want to get rid of cookies on your static content you need to set up subdomain to serv static content. You can use W3 Total's self hosted CDN features to serve the content. You will have to set up the subdomain in cpanel then enter the cname into W3 along with your ftp information and follow the instructions.

    To remove the cookies from the subdomain add this line to your config.php: define('COOKIE_DOMAIN', 'www.usbmemorysticks.net');

    AskApache has a good article on setting up cookieless sub domains with WordPress

    Thanks for the information. I dont think I want to look into this right now, maybe at a later point. Main thing is that this doesnt cause any problems. Once again thanks!

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Only the object cache and/or database cache will reduce response time for posting comments and creating new cached pages.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic