WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Entering comment hangs at wp-comments-post.php (18 posts)

  1. rsknowles
    Member
    Posted 4 years ago #

    When W3TC is enabled and a user posts a comment it freezes at wp-comments-post.php. When logging in as administrator the comment is visible in the list of new comments but the users browser never redirects to the new page.

  2. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Are there errors in your error log? Does the same occur if you temporarily switch to the twentyten theme for example?

  3. johnbl4ck
    Member
    Posted 4 years ago #

    i confirm this issue, after upgrading to 0.9.1.1 this error, reset 0.9.1.1 settings to their defaults but with no luck

  4. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Can anyone who is having this issue submit a bug submission from the support tab of the plugin?

  5. sdamy
    Member
    Posted 3 years ago #

    I've this issue and I've submit a bug submission

    thanks

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Anyone here using xcache?

  7. rsknowles
    Member
    Posted 3 years ago #

    When I display results from phpinfo(), xcache is not listed -- if that's an accurate indication of its usage.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Anyone here using object caching?

  9. KimJCastleberry
    Member
    Posted 3 years ago #

    Im using object caching with memcached enabled, but I'm not affected by this bug.

    This would be an odd troubleshoot but I've seen it work before. Sometimes plugins addle the wp-comments-post.php file in a way that it white screens. This isnt unique to w3tc. To rule out a file issue I usually start the more rigorous troubleshoot by pushing a clean copy of wp-comments-posts.php up to the server. Doesnt always help, but sometimes it does. Dont know why some things mess with that file. A search for "blank screen after wp-comments-posts" usually turns up a bunch of ideas.

    Not sure that will help but wanted to toss it out here since this seems to be affecting several.

  10. rsknowles
    Member
    Posted 3 years ago #

    In my latest test I am only using page caching. I performed a file compare of my copy of wp-comments-posts to a fresh copy and found no differences. I did notice an extra carriage return following the closing PHP tag which I removed but it did not resolve the problem either.

  11. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I've still not gotten to the bottom of this. Anyone else with more info?

  12. z4reg
    Member
    Posted 3 years ago #

    Having same issue ..when page cache is enable in disk or disk enhanced mode :(

    compatibility test result

    [Moderator note: snipped code blocks, please use the pastebin as per the Forum Guidelines]

  13. z4reg
    Member
    Posted 3 years ago #

  14. Theiceman6
    Member
    Posted 3 years ago #

    Same Problem as z4reg.

    What to do?

  15. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Anyone having this issue please try the development version of the plugin and if the problem persists please submit a bug submission form from the support tab of the plugin.

  16. z4reg
    Member
    Posted 3 years ago #

    Thanks Frederick :)

    Issue seems to be fixed. Will continue to test it...

    Also new UI changes are nice!

    Having issues with cloudflare .. "Unable to make CloudFlare API request."

    Also Page Cache (Enhance Disk Mode) and Browse cache whenever enable, its asking configuration file change but doesn't show code after clicking on view code and auto-install seems to be not working. Message "The browser cache rules could not be modified. Please create an empty file in and run chmod 777 to resolve this issue." which file are we taking about here?

    Once again thanks for the update.

    edit: JS minify is seems to be removing google lib jqeury! ... having trouble.

  17. Paul
    Member
    Posted 3 years ago #

    Today I noticed I was having this problem as well. Disabling Database Caching (Disk) seems to have resolved the issue. I'm not using Object Cache.

    There's still a slight hang on wp-comments-post.php, but it's much less than it was, and the user does now get redirected to the proper page.

    I'm on a MediaTemple GridServer (gs), so using Database Caching was questionable anyway.

  18. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @z4reg, submit a bug submission form from the support tab of the plugin for those various cases.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic