WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] EAccelerator 0.9.6 not being recognized by w3 total cache (15 posts)

  1. Nevensky
    Member
    Posted 4 years ago #

    Greetings,

    I have successfully installed and configured my eaccelerator (v 0.9.6) and my php info clearly shows:

    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with eAccelerator v0.9.6, Copyright (c) 2004-2010 eAccelerator, by eAccelerator

    However when I enter w3 total cache configuration I am unable to select eaccelerator in the caching method... it seems as if eaccelerator is not installed. See the screenshot: http://img1.uploadscreenshot.com/images/main/6/17105540267.jpg

    Why is this happening? Is this a bug with w3 total cache? When is it going to be fixed?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    The latest version of eAccelerator that supports user object caching is v0.9.5.3.

  3. jonno225
    Member
    Posted 4 years ago #

    Hi, we are suffering from the same issue.
    We had eAccelerator v0.9.6 and could not select the option for it within W3 Total Cache.

    We have now installed eAccelerator v0.9.5.3 (# php -i | grep -i eacc)
    But still have the same problem and the only caching methods we can select are the disk ones in W3.

    Any ideas?
    Many thanks
    Jon

  4. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    If it's installed properly and v0.9.5.3 it should work. You can test on command line using:

    php -r "var_dump(function_exists('eaccelerator_put'));"

    If the above returns nothing, then user object caching won't work. Obviously you'll want to use the monitoring scripts as well to make sure that it's otherwise functioning properly.

  5. jonno225
    Member
    Posted 4 years ago #

    well,
    php -r "var_dump(function_exists('eaccelerator_put'));"

    Just returns - bool(false)

  6. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    So you cannot store user objects then. This is not a W3TC bug/issue. I added support for this because people asked for it, not because I recommend it.

  7. jonno225
    Member
    Posted 4 years ago #

    Thanks for the reply.

    So is eAccelerator not installed or configured correctly then?

    We are pretty new to this sort of stuff and our VPS provider has set our system up for us at the moment.

    Many thanks
    Jon

  8. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    It would seem. Unfortunately, I've seen instances of xcache and eaccelerator not working properly on some operating systems. I typically recommend in any case.

  9. jonno225
    Member
    Posted 4 years ago #

    Thanks again,

    We originally wanted to use APC but this apparently has problems with the Zend Optimizer (which we also need) so we opted for eAccelerator.

    We really need to find a solution to this if anyone has any ideas on how we can configure eAccelerator correctly.

    many thanks
    Jon

  10. jonno225
    Member
    Posted 4 years ago #

    OK, this issue has now been sorted so I thought I would share how our VPS provider fixed it in case anyone else is having similar problems.

    The solution was to recompile eAccelerator with '--with-eaccelerator-shared-memory'

    So now # php -r "var_dump(function_exists('eaccelerator_put'));"

    Outputs a result of - bool(true)

    eAccelerator is now available for selection in W3 Total Cache

  11. remotay
    Member
    Posted 4 years ago #

    Jonno225,

    What sort of results are you seeing as eAccelerator usage for Minify / DB Cache? From what i've read on these forums and from numerous tests, the most optimized setup is Disk Enhanced for page cache, and APC / Eaccelerator for Minify / DB cache. I'm sure it varies from server to server though.

  12. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    @jonno225 is it --with-eaccelerator-shared-memory or --with-eaccelerator-shared ?

  13. jonno225
    Member
    Posted 4 years ago #

    @remotay
    We are definitely seeing some improved performance with the different caching options switched on. However it's early days and we are still testing. I will try and report back here with any results.
    It may actually turn out that we cannot use the page cache at all as we are running a membership site that renders the pages differently depending on whether users are logged in or not.
    We do hope to use the Minify, DB Cache and CDN stuff though.
    Maybe someone can advise on this.

    @fredericktownes
    I believe it was with '--with-eaccelerator-shared-memory'

    Thanks
    Jon

  14. invi2003
    Member
    Posted 4 years ago #

    jonno225 that really worked for me as well. I ran ./configure \--with-eaccelerator-shared-memory
    and the option for eaccelerator is available

  15. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Thanks all.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic