WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] dont work minify (32 posts)

  1. nubic
    Member
    Posted 4 years ago #

    add css and js files in minify settings
    file like default.include.css are create but its not work because when file calls we have error HTTP/1.0 400 Bad Request
    and stylesheet at page are not loading

    and another

    the date 1970-01-01 is it normal?
    Stylesheet info:
    Location | Last modified | Size | Path
    include | 1970-01-01 00:00:00 | | wp-content/plugins/contact-form-7/styles.css?ver=2.1

  2. Frederick Townes
    Member
    Posted 4 years ago #

    wp-content/plugins/contact-form-7/styles.css?ver=2.1

    You need to use the full URL when CSS or JS files have ?ver=2.1 for example. Also some files cannot be minified so if you have an issue you need to test one-by-one or check the wp-content/w3tc/log/minify.log if there are still errors.

  3. nubic
    Member
    Posted 4 years ago #

    i reed the faq and do this
    and test one by one
    check with [verify URI] and i see files added
    wp-content/w3tc/log/minify.log is not created. i create them myself and chmod 666 then his wrote
    [/wp-content/w3tc/min/default.include.css] The path "/var/www/account/data/www/site.com/wp-content/plugins/contact-form-7/styles.css?ver=2.1" could not be found (or was not a file)

    and another i wrote full url and save settings but when open minify settngs i see short in CSS and JS file management

  4. Frederick Townes
    Member
    Posted 4 years ago #

    If minify cannot find the file, it cannot build the cache. Are you sure that file exists on your server?

  5. nubic
    Member
    Posted 4 years ago #

    i experiment whith php.ini and dont know what am i don :D
    files whithout strings wariables are cashe now,
    but with wariables are not and adding full url is not helpfull and file's 100% exist

  6. nubic
    Member
    Posted 4 years ago #

    i wrote full url in w3-total-cache-config.php and it works, dont work only if adding url from admin panel because its automaticly shorts by plagin i think, but i dont know why

    and when i add another url and save settings his again short all urls and agains we hav eror 400 bad reqest instead default.include.css file

  7. Frederick Townes
    Member
    Posted 4 years ago #

    This is not a known bug, would you mind trying a re-install so that all we can be sure that something else isn't going wrong?

  8. nubic
    Member
    Posted 4 years ago #

    after reinstall everything works thanks
    but i have some any questions
    1 i want to translate plugin but i cant see any support internationalization like e_() in WP, can you in next releases include support translations with .po .mo files

    2 i don some tests and minifyed files are not cash and gzip
    like

    file                     size      min size(gzip)     cache (s)
    / (html)                 12511	    12434              1070
    default.include.css      13994	    2543                 0
    show_ads.js adsense      11143       -                 86400
    default.include.js       71086	    23143                -
    headers
    HTTP/1.1 200 OK
    Server: nginx/0.7.64
    Date: Mon, 18 Jan 2010 12:13:11 GMT
    Content-Type: application/x-javascript
    Content-Length: 71086
    Last-Modified: Mon, 18 Jan 2010 11:29:59 GMT
    Connection: keep-alive
    Accept-Ranges: bytes

    Up to 47891 bytes could have been saved through compression.

  9. Frederick Townes
    Member
    Posted 4 years ago #

    minifyed files are not cash and gzip

    Do you mean that the files are not created on your server?

    i cant see any support internationalization

    Please email me through the bug submission form on the support tab so we can speak further.

  10. nubic
    Member
    Posted 4 years ago #

    files created but headers without
    Content-Encoding: gzip
    Cache-Control: public, max-age=86400
    or its normal

    or may be users dont get compressed default.include.css.gz file only default.include.css
    becose tests show size css 13994 kb but gziped file has size 2543 kb

  11. Frederick Townes
    Member
    Posted 4 years ago #

    Which tests? Try http://web-sniffer.net/

  12. nubic
    Member
    Posted 4 years ago #

    Server:	nginx/0.7.64
    Date:	Mon, 25 Jan 2010 20:31:34 GMT
    Content-Type:	text/css
    Content-Length:	13994
    Last-Modified:	Mon, 25 Jan 2010 11:16:04 GMT
    Connection:	close
    Accept-Ranges:	bytes	
    
    Content (13.67 KiB)
    Server:	nginx/0.7.64
    Date:	Mon, 25 Jan 2010 20:34:25 GMT
    Content-Type:	application/x-javascript
    Content-Length:	71086
    Last-Modified:	Mon, 25 Jan 2010 11:16:10 GMT
    Connection:	close
    Accept-Ranges:	bytes

    and main html

    Server:	nginx/0.7.64
    Date:	Mon, 25 Jan 2010 20:35:07 GMT
    Content-Type:	text/html; charset=UTF-8
    Transfer-Encoding:	chunked
    Connection:	close
    X-Powered-By:	W3 Total Cache/0.8.5.1
    Pragma:	public
    Expires:	Mon, 25 Jan 2010 21:28:23 GMT
    Last-Modified:	Mon, 25 Jan 2010 20:28:23 GMT
    Cache-Control:	max-age=3196, public, must-revalidate
    Vary:	Accept-Encoding,Cookie
    Etag:	e03bebe7b1b53a899b2fef04dacac954
    Content-Encoding:	gzip	
    
    Content (encoded: 12.50 KiB / decoded: 55.13 KiB)
  13. Frederick Townes
    Member
    Posted 4 years ago #

    Sorry for not catching this earlier, but nginx is not yet supported.

  14. ktomov
    Member
    Posted 4 years ago #

    Hope that there are plans for nginx support in the near future.
    I am using it for a week after migrating from apache and I am impressed. The only thing that I miss is good caching plugin. Wp-Supercache is not good to me.

  15. Frederick Townes
    Member
    Posted 4 years ago #

    Nginx definitely has it's strengths. Lighttpd and nginx are in the roadmap scheduled after finalization of other key features. If anyone blogs about the changes they've made (users are implementing it themselves I hear) I'll make sure to share them.

  16. ktomov
    Member
    Posted 4 years ago #

    I've searched a lot today and still nothing.
    If someone have managed to implement the plugin with nginx, it would be great to share how he had done it.

  17. Frederick Townes
    Member
    Posted 4 years ago #

    No one has posted anything yet. As soon as I find a case I'll either post an FAQ or otherwise make sure it's easy info' to find.

  18. error
    Member
    Posted 4 years ago #

    I also use nginx, and everything works except for CSS/JS minify. So far I just haven't bothered to put in the time to figure out why.

  19. Frederick Townes
    Member
    Posted 4 years ago #

    There's just one rewriterule required for basic minify operation. If someone wants to contribute some directives it would be appreciated, I haven't finished the task myself.

  20. error
    Member
    Posted 4 years ago #

    I'll play with it this weekend; it shouldn't be too hard to work in the rewrite rule.

  21. Frederick Townes
    Member
    Posted 4 years ago #

    Thanks

  22. crashdump
    Member
    Posted 4 years ago #

    Any news ? i have the same problem: 400 Bad request when I enable Minify (with no url rewrite because i don't know the correct rules to configure.)

  23. crashdump
    Member
    Posted 4 years ago #

    ok-- deleted my .js/.css files and reinstalled the script -- everything is ok now.

  24. RandomMan01
    Member
    Posted 4 years ago #

    Hi There, I am having the same 400 Bad request problem when I input my css files to minify. Some of the URIs get rewritten to just the /wp-content/ part, removing the site address from the beginning.

    I have tried to remove the .js and .css and reinstalled the plugin, but unlike these guys, mine isn't working after doing that.

    Any help would be appreciated.

    Thanks

  25. godkid
    Member
    Posted 4 years ago #

    seems like the same issue I'm currently having - but thanks to pointing to the error log I've found what the problem is (not that I can fix it)..

    the absolute address that the plugin is reporting is wrong. As per nubic's post - the error I find in my situation is that the path is written twice so that instead of /x/y/z/abc.css I'm getting /var/chroot/x/y/z/x/y/z/abc.css

    Any ideas on a fix?

    ** re-install didn't work

  26. Frederick Townes
    Member
    Posted 4 years ago #

    RandomMan01 and godkid what errors do you have in your error log or /wp-content/w3tc/log/min.log file (if it exists that means you have errors with minify as opposed to PHP)?

  27. godkid
    Member
    Posted 4 years ago #

    my issue was resolved using the dev version as per your suggestion here

  28. huwr
    Member
    Posted 4 years ago #

    also getting this error.

    HTTP/1.0 400 Bad Request

    it looks like min/index.php is loading fine, and correctly calling instance(). From there, I haven't found where the script is erroring out.

    No logfiles exist in the log/ directory.

  29. huwr
    Member
    Posted 4 years ago #

    ok, i put a custom error handler in there..

    [type] => 2048
    [message] => Non-static method W3_Config::instance() should not be called statically, assuming $this from incompatible context
    [file] => Minify.php
    [line] => 44

  30. RandomMan01
    Member
    Posted 4 years ago #

    Hi Frederick,
    I don't have a min.log file, what does that mean? I will give the dev version a go and see how it goes.

    huwr, where did you insert that code, into the index.php file?

    Thanks again,
    Random

Topic Closed

This topic has been closed to new replies.

About this Topic