WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Do not minify front page? (6 posts)

  1. schneeb
    Member
    Posted 1 year ago #

    This plugin is great at reducing load time, but I am having a conflict with my front page.

    My front page is set to display a static page (an initial landing page). Currently, minify breaks additional scripts I've linked to on that page. I've tried to set 'Never minify the following pages' to these particular JS pages or the template pages themselves with no prevail.

    How can I include the front page to 'Never minify the following pages'? I'm not 100% sure of the structure. I've tried a simple '/' but that blocks all pages from being minified.

    Any help would be greatly appreciated! :D

    http://wordpress.org/extend/plugins/w3-total-cache/

    [No bumping. If it's that urgent, consider hiring someone or or asking on the #wordpress IRC Channel.]

  2. akarmach
    Member
    Posted 1 year ago #

    I'm having the exact same issue. I'm quite sure this wasn't the case for previous versions. I think it may be a bug in the latest release.

    Frederick?

  3. schneeb
    Member
    Posted 1 year ago #

    I ended up resolving this issue:

    Under General Settings, I set Minify to manual. Then under Minify, I specified which JS/CSS files to minify, so it doesn't effect the scripts I still needed to function.

    This actually proved to be very beneficial, because I was able to determine a few other plugin conflicts it was causing that I was able to correct.

  4. akarmach
    Member
    Posted 1 year ago #

    Thanks for the advice!

    You know, I was thinking about doing this, but I didn't want to go through and identify all the various JS / CSS files to minify. You have a tip for doing this effectively?

  5. schneeb
    Member
    Posted 1 year ago #

    I thought it would be painful and time consuming, but it was actually quite easy. You can simply view the page source or use a browser plugin such as firebug to determine the files. I did a simple search both for '.js' and '.css' and then began adding those files to the corresponding list. It may be best to do it a few at a time to determine where the conflict is arising.

  6. akarmach
    Member
    Posted 1 year ago #

    hmm.. sounds straight forward enough.. ok, I'm sold! Thanks again for the advice!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic