WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Disk-enhanced page caching impossible w/o permalink trailing slash? (27 posts)

  1. Sam_a
    Member
    Posted 2 years ago #

    Hi Frederick,

    I upgraded to 0.9.2.1 and saw this message:

    The permalink structure (/blog/%postname%) does not include a trailing slash, disk enhanced page caching will fail to cache most requests. Either switch to any other supported caching method or add a trailing slash in the settings.

    My permalink structure does indeed lack a trailing slash, and with earlier versions of the plugin I had removed this rule in .htaccess —

    RewriteCond %{REQUEST_URI} \/$

    — and disk-enhanced page-cache files (wp-content/w3tc/pgcache/*) seemed to be served with no problem. Can I continue to do this and still use disk-enhanced page caching successfully?

    Thanks, Sam

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Oliver Krautscheid (oliversk)
    Member
    Posted 2 years ago #

    May I second that, I'd even be willing to pay for this feature.

    Please let us know if we can remove the RewriteCond or if we'll run into any problems

    For SEO reasons its impossible to add a trailing slash and I'm sure that there are many others out there who don't want to update their permalink structure and mess around with some 301 redirects. Goolge will index both in the end if you don't take care..

    Anyway, W3T is pretty cool, nice work!
    Oliver

  3. Galerio
    Member
    Posted 2 years ago #

    Same things here, my permalink structure ends with .html so I cannot add a trailing slash and everything has always worked fine.

  4. milez
    Member
    Posted 2 years ago #

    Same here...Got this message after upgrading to 0.9.2.1 and now cannot re-activate the plugin. Hopefully the developers are reading this :/

  5. milez
    Member
    Posted 2 years ago #

    Ouch...none of my pages cache now. My pages end in *.html.

    Caching: disabled
    Reject reason: request URI doesn't have a trailing slash

    This was a strange change to make as I noticed that even for category pages like domain.com/my-category/ (WITH the trailing slash) these forward to a non-trailing slash version and are then not cached as well!

    Guess we need to roll back to an older version until this is addressed .. ?

  6. pbsbluejay
    Member
    Posted 2 years ago #

    Same here, I'm getting this error...

    "The permalink structure (/%postname%) does not include a trailing slash, disk enhanced page caching will fail to cache most requests. Either switch to any other supported caching method or add a trailing slash in the settings."

    I don't want to alter /%postname% if it's going to affect my SEO and cause me to lose traffic. My other site ends in *.html. I've never seen anyone use a permalink *.html/

    So it appears one option is install another cache plugin like WP Super Cache which I don't like or keep W3TC and add the ending slash then do 100s of redirects for all of my sites.

  7. hydn
    Member
    Posted 2 years ago #

    keep W3TC and add the ending slash then do 100s of redirects for all of my sites.

    SEO, you already chose .html. Software should meet your config. Dont to that.

  8. milez
    Member
    Posted 2 years ago #

    Submitted a bug report. Hopefully Frederick sees this thread soon :/

  9. papek
    Member
    Posted 2 years ago #

    Hello Frederick, can you please let us know;

    Why does the new W3TC plugin version forces sites and blogs adding trailing slash at the end of url's?

    Many people use .html or .php etc. at the end for years. Many sites/blogs also use %postname% instances with no the ending trailing slash.

    * Is there a related fix by support if we pay you a support fee you require?? Or how to set this up.

    With compliments and anticipation! Thank you.

  10. Mike McKoy
    Member
    Posted 2 years ago #

    where is everyone seeing that error?

    I haven't seen it myself but I wonder if i'm not looking in the right place.

  11. milez
    Member
    Posted 2 years ago #

    It's not an error, it appears to be by design. I'm really surprised they did not think this would effect a lot of people. We upgraded to the latest version of W3TC and caching has stopped working due to our URLs not ending in a trailing slash. Very strange as last I checked .html was a pretty common extension for HTML pages.

    If you want to see if this effects you turn on page caching and the debug code for it. Then view-source on one of your posts/pages. Look for the message below.

    Caching: disabled
    Reject reason: request URI doesn't have a trailing slash

  12. Oliver Krautscheid (oliversk)
    Member
    Posted 2 years ago #

    The basic disk mode seems to be buggy as well.

    I've been using it for a couple days and today I noticed that when W3T Page cache (basic disk) is enabled, it sometimes turns the permalinks into the regular links (p=2039), disabling the permalinks completely.

    How would I create a debug report?

  13. Mike McKoy
    Member
    Posted 2 years ago #

    Has anyone successfully reverted to an earlier version? Doesn't look like a fix is coming soon. Must be a lot wrong with this new version.

  14. hydn
    Member
    Posted 2 years ago #

    Use WP Super Cache. It now includes CDN support also have a look at how active the developer is with the community.

    Good luck!

  15. Mike McKoy
    Member
    Posted 2 years ago #

    i'll try it... i thought w3 cache was rated as the best in the business?

  16. hydn
    Member
    Posted 2 years ago #

    Its great dont get me wrong there's just too many bugs. But for me its a lot about support. The WP Super Cache developer is a genius who is friendly, humble and "very active" in the forums:

    http://wordpress.org/tags/wp-super-cache?forum_id=10

  17. pbsbluejay
    Member
    Posted 2 years ago #

    Did anyone install the new update yet - 0.9.2.2 version?

    Does it still ask for a trailing slash for the permalink?

  18. Mike McKoy
    Member
    Posted 2 years ago #

    Not really sure if it totally works but the changelog says its fixed. I haven't installed it yet however but will soon.

    http://wordpress.org/extend/plugins/w3-total-cache/changelog/

  19. max_Q
    Member
    Posted 2 years ago #

    So I installed the latest(?) development version (marked 0.9.2.2b) and I get this in my debug code:

    Engine: disk (enhanced)
    Cache key: _index.html
    Caching: disabled
    Reject reason: Requested URI has a trailing slash
    Status: not cached

    Ironic, huh. This is on my home (loop) page. When I go to my about page, which has no trailing slash, here's what I get:

    Engine: disk (enhanced)
    Cache key: about/_index.html.gzip
    Caching: enabled
    Status: not cached

    Not cached, no reason given. I'm logged out at the time, and refreshed a couple of times. Don't see any files in pgcache. Seems like, one way or another, no caching for me.

    Version 0.9.2.2 mentions:
    Fixed bug with fancy permalinks, sites with or without trailing slashes can now cache pages using disk enhanced.

    If this is the same bug it seems like it's still happening.

  20. Sam_a
    Member
    Posted 2 years ago #

    @max_Q: I also see "Reject reason: Requested URI has a trailing slash" in the page cache debug message for my home page using 0.9.2.2 (my permalinks lack trailing slashes).

    I think this is a new bug that came with a new feature — instead of rejecting all URLs with a trailing slash, 0.9.2.2 caches only URLs that match your permalink structure (i.e. with or without a trailing slash). It should skip that check for the home page URL (/), which always has a trailing slash.

  21. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    This issue is fixed in the latest release.

  22. awhig
    Member
    Posted 2 years ago #

    I am running 0.9.2.3 and when I view debug info for my home page, it says it is not caching it due to the slash...

    Please help.

    <!-- W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Cache key: _index.html
    Caching: disabled
    Reject reason: Requested URI has a trailing slash
    Status: not cached
    Creation Time: 1.739s
    Header info:
    X-Pingback: http://www.------.com/-----/xmlrpc.php
    Content-Type: text/html; charset=UTF-8
    X-Powered-By: W3 Total Cache/0.9.2.3

  23. awhig
    Member
    Posted 2 years ago #

    When Frederick said:

    >>This issue is fixed in the latest release.

    Did he mean in 0.9.2.4?

    I think he did, as the code that generates the reject reasons in .4 is vastly different than .3.

    Rich

  24. Galerio
    Member
    Posted 2 years ago #

    Also in 0.9.2.4 there is this issue, but not only for homepage or pages with or without trailing slash, it is for all pages!!! See here:
    http://wordpress.org/support/topic/bug-disk-enhanced-cache-doesnt-work-in-0924

  25. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    W3TC now has an option that allows you to cache all requests or only those consistent with your site URL. Please have a look at that option and let me know if you're still having the issue via a bug submission form from the support tab of the plugin.

    I also recommend checking out the development release.

  26. Galerio
    Member
    Posted 2 years ago #

    Thanks Frederick, I'm already using the latest development release (0.9.2.5b) and I have the issue on 5 different blogs.

    I have tryed Disc Enhanced with and without "Cache requests only for 12n3.com hostname" but the result is the same: status not cached.

    I have already submitted the bug via support tab. I'll do it again.

  27. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic