WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Disk (enhanced) option disabled (30 posts)

  1. Luciano Passuello
    Member
    Posted 3 years ago #

    The option "Disk (Enhanced)" is disabled, leaving me with only "Disk (Basic)" for page cache option. I'm not 100% sure, but it seems that in previous versions (I'm on 0.9.2.1 now ) I had "Disk (Enhanced)" selected with no problems.

    Does anyone have any ideas why it is disabled? And how to enable it back on?

    Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. robnalexpress
    Member
    Posted 3 years ago #

    FWIW, I'm running 0.9.2.1 with Disk (Enhanced) enabled.What do you mean by the option is "disabled"?

  3. Luciano Passuello
    Member
    Posted 3 years ago #

    Disabled = grayed out. That means that although it's in the list of options, it's not possible for me to select it.

    Also, W3TC doesn't give me any warnings or other hints on why it's not enabled.

  4. robnalexpress
    Member
    Posted 3 years ago #

    Something's not right. You might want to uninstall and reinstall?

  5. esmi
    Forum Moderator
    Posted 3 years ago #

  6. Hayden James
    Member
    Posted 3 years ago #

    Luciano any success on a fix?

  7. Luciano Passuello
    Member
    Posted 3 years ago #

    Reverting to 0.9.1.3 fixes the problem (disk enhanced is enabled, and works fine).

    As soon as I upgrade to 0.9.2.1 again, disk (enhanced) is disabled and the only selectable option is disk (basic). No warnings, no error messages.

  8. agniveer
    Member
    Posted 3 years ago #

    I am also facing the same issue. Disk Enhanced is disabled by default. So htaccess rules are not generated.

    I am not sure if W3 Total cache with basic disk cache is better or supercache/ hyper cache?

    I am on a shared server.

    If anyone can help, kindly guide.

  9. MTPrower
    Member
    Posted 3 years ago #

    I also have this problem.

  10. microtag
    Member
    Posted 3 years ago #

    After updgrade to new version I've same problem.
    Disk (enhanced) option disabled.

  11. MegaZone
    Member
    Posted 3 years ago #

    Have you run the 'Compatibility Check' to see if it flags anything?

  12. microtag
    Member
    Posted 3 years ago #

    I have downgrade to 0.9.1.3 and now works fine.

  13. MTPrower
    Member
    Posted 3 years ago #

    @microtag

    I'm not downgrading any software. Keeping your software up-to-date is important for security and for keeping it working properly...

  14. Hayden James
    Member
    Posted 3 years ago #

    I'm not downgrading any software. Keeping your software up-to-date is important for security and for keeping it working properly...

    rofl.

    anyway wp super cache is faster and the developer is not arrogant.

  15. MTPrower
    Member
    Posted 3 years ago #

    I consider myself to be arrogant, but anywho...

    W3 Total Cache supports CloudFlare, so I'm not sure I want to switch. I've tried Super Cache before I started using W3 Total Cache. Before that, I was using Hyper Cache. I don't really know what's the best for me. I do want to make sure my CDN, CloudFlare, is supported...

  16. Hayden James
    Member
    Posted 3 years ago #

    CloudFlare makes their own WordPress plugin. So not sure what your point is there. I also use "CDN Sync Tool" to auto upload my images to Amazon Cloudfront.

    Good luck with W3. For me the best plugins are the ones where the developers are most in-tune and active with its users.

  17. microtag
    Member
    Posted 3 years ago #

    @MTPrower

    you're right!
    but not works and not cached!
    I await new release or I'll have to change plugin.

  18. microtag
    Member
    Posted 3 years ago #

    Have you run the 'Compatibility Check' to see if it flags anything?

    PHP Version: 5.2.17
    PHP Timezone: Not set
    Web Server: Lite Speed
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected

    WordPress Resources
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

  19. Luciano Passuello
    Member
    Posted 3 years ago #

    Just upgraded to 0.9.2.2 and the problem persists... :(

    For reference, here are my compatibility settings:
    Server Modules & Resources:

    Plugin Version: 0.9.2.2
    PHP Version: 5.2.15 (PHP5 required for Minify, Rackspace CloudFiles, Microsoft Azure support)
    Web Server: Lite Speed
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    HTML Tidy extension: Not installed (required for HTML Tidy minifier suppport)
    Mime type detection: Not installed (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off

    WordPress Resources

    : Not write-able
    /home/(...): OK
    /home/(...): OK
    Fancy permalinks: /%postname%/
    WP_CACHE define: Defined (true)
    Network mode: No

  20. thiagomedeiros
    Member
    Posted 3 years ago #

    I'm with the same error =/

    Compatibility Test

    Plugin Version: 0.9.2.2
    PHP Version: 5.2.17 (PHP5 required for Minify, Rackspace CloudFiles, Microsoft Azure support)
    Web Server: Lite Speed
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    HTML Tidy extension: Installed (required for HTML Tidy minifier suppport)
    Mime type detection: Not installed (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: On: /home/thiagome:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp
    zlib output compression: Off

    WordPress Resources

    : Not write-able
    /home/thiagome/public_html/blog/wp-content: OK
    /home/thiagome/public_html/blog/wp-content/uploads/2011/06: OK
    Fancy permalinks: /%category%/%postname%
    WP_CACHE define: Defined (true)
    Network mode: No

    WordPress 3.1.3

  21. Luciano Passuello
    Member
    Posted 3 years ago #

    Just upgraded to 0.9.2.3, and the problem still persists. One thing that I noticed (which is probably causing the issue) is that W3TC didn't add rules to my .htaccess.

    I tried uninstalling, changing permissions in htaccess to 777, reinstalling it, but W3TC doesn't seem to touch htaccess. I don't get any error messages or warnings, so I'm not sure how to proceed.

    Any help is appreciated!

  22. thiagomedeiros
    Member
    Posted 3 years ago #

    I think W3 Total Cache don't use .htacess with litespeed servers.

  23. Luciano Passuello
    Member
    Posted 3 years ago #

    It does in W3TC 0.9.1.x.

  24. Luciano Passuello
    Member
    Posted 3 years ago #

    Digging into the code I finally found what's causing this. And yes, it's related to LiteSpeed. It turns out that LiteSpeed is 100% compatible with Apache (uses htaccess, etc.), but the code that detects compatibility looks specifically for 'apache' as the server name.

    IN version 0.9.2.3, replace the line 440 in w3-total-cache/inc/define.php:
    return (isset($_SERVER['SERVER_SOFTWARE']) && stristr($_SERVER['SERVER_SOFTWARE'], 'apache') !== false);

    with
    return (isset($_SERVER['SERVER_SOFTWARE']) && (stristr($_SERVER['SERVER_SOFTWARE'], 'apache') || stristr($_SERVER['SERVER_SOFTWARE'], 'LiteSpeed')) !== false);

    Hope this helps someone!
    (I'll try to contact Frederick directly regarding this issue in case he's not listening to this thread)

  25. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Litepseed is not 100% compatible with apache in practice. For that that reason apache is detected and handled reliably, just like nginx is. Litespeed needs more testing to handle it's nuances.

  26. Luciano Passuello
    Member
    Posted 3 years ago #

    Thanks for your response, Frederick!

    For the record, I've been using W3TC pre-0.9.2 for a long time with Litespeed and never ran into any issues, but thanks for letting me know that compatibility is a bit more messy than it seems.

    Do you plan to add support for Litespeed in future versions of W3TC?

  27. Everton
    Member
    Posted 3 years ago #

    Thank you for finding this Luciano!!

    Frederick - maybe add this to the FAQ? A lot of people have wasted a lot of time trying to find this answer/solution

  28. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble, Litepseed support is coming in the next release, so there's no need for a FAQ update, it still works for some people as Luciano noted.

  29. dharma.arte
    Member
    Posted 2 years ago #

    Any news about the next release with Litespeed support? I've been having problems using W3TC with Litespeed for CDN/Rackspace. As it's working perfectly with Apache, I think it has to do with Litespeed...

  30. eva2000
    Member
    Posted 2 years ago #

    Using litespeed fine with w3tc here, what i did was moved all .htaccess into httpd.conf which litespeed reads from and supports. Then in w3tc disable browser caching and httpd compression (both already enabled by litespeed).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic