WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
CSS file not loading properly. (5 posts)

  1. jefflovell
    Member
    Posted 3 years ago #

    I've setup W3 Total Cache on a couple of sites and it works great. However, on one site in particular I've run into a couple of issues that I can't resolve on my own. Could you please lend a hand?
    On this site, watershedstoughton.com you can see the site as it should look/load. Presently, CDN and minify are disabled in order to load correctly.
    When I enable minify, the image slider stops working, and I can't find out where the problem lies.
    When I enable CDN, the page loads to look like this (http://img641.imageshack.us/i/cssmissing.png/). The CSS file that renders the page correctly is dynamically created by my (Striking) theme settings in the file wp-content/themes/striking/css/skin.php. I've tried excluding that file from the CDN, but that doesn't resolve the problem. I'm not sure what to try next.
    I would sincerely appreciate any help you can provide. Thank you.

  2. kfawcett
    Member
    Posted 3 years ago #

    I'm not the developer, but may be able to help.

    When I look at the source file of your site it is showing Minify as being enabled and everything on the site seems to be working fine. The only thing that doesn't show is the CDN. Are you sure it's not the CDN that is causing the problem?

    Minified using disk

    Page Caching using disk (enhanced)

    Database Caching 9/11 queries in 0.002 seconds using disk

    Object Caching 1231/1231 objects using disk

    Served from: watershedstoughton.com @ 2011-01-12 15:51:02 -->

    Have you tried to minify only one set of files at a time. Maybe start all the JS files and see if everything works. If it breaks, minify only one JS file at a time to see if any of them are causing a problem. Then only minify the CSS files. If something breaks, do the same as the JS files. Only minify one at a time until you find one that breaks.

    If the code in a file isn't written correctly minifying it, removing white space, and line breaks can cause errors and your site to not load correctly.

    Once you are able to correct all the issues and everything is minified correctly, then try to upload all the files and enable the CDN.

  3. jefflovell
    Member
    Posted 3 years ago #

    Thanks for your help. You are correct that I've been able to enable minify, and slowly adding one file at at a time to see what works.
    However, I still have the problem with the CDN as it relates to my CSS file.

    When I enable CDN, the page loads to look like this (http://img641.imageshack.us/i/cssmissing.png/). The CSS file that renders the page correctly is dynamically created by my (Striking) theme settings in the file wp-content/themes/striking/css/skin.php. I've tried excluding that file from the CDN, but that doesn't resolve the problem. I'm not sure what to try next.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The problem is that the paths to the objects in your CSS file cannot be found or the files use @import or both. The development release handles these cases better. You will have to review the file and see if the URLs to each object are correct.

  5. johnddd
    Member
    Posted 2 years ago #

    I seem to have a similar problem. When I enabled CDN with Cloudfront, the site lost all shape.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic