WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Comments posting slow (8 posts)

  1. bobmorris60
    Member
    Posted 3 years ago #

    I installed W3 on Friday. Everything is faster, except for posting comments, which is very slow, like 10 seconds for me logged in and not logged in. Site is http://polizeros.com. Any ideas?

    General Settings Page
    ----------------------
    Page / minify / database / object cache enabled - Disk

    Page Cache Settings
    -------------------
    Don't cache for logged in users, Cache Home Page, Cache feeds are checked

    Never cache
    wp-.*\.php
    index\.php

    Cache exception list:
    wp-comments-popup.php
    wp-links-opml.php
    wp-locations.php

  2. bobmorris60
    Member
    Posted 3 years ago #

    I also just got an error message after clicking Update in WP Edit to post a new post. But the post itself actually was posted. This isn't a WP error message, is it from W3TC?

    "This website is temporarily unavailable. Please check back later.

    Unfortunately there were no suitable nodes available to serve this request."

    Any ideas what I can do?

  3. Frederick Townes
    Member
    Posted 3 years ago #

    Why do you have every caching type enabled and using disk? Start with the default settings and tune things respectively.

  4. bobmorris60
    Member
    Posted 3 years ago #

    That's how tech support at my host set it up for me, they're usually pretty good. Will try the default settings. Thanks.

  5. bobmorris60
    Member
    Posted 3 years ago #

    I just did Restore Default Settings and all the options I originally listed are still checked.

    What would you advise starting with? The site gets 1,000-2,000 visits a day or so.

  6. bobmorris60
    Member
    Posted 3 years ago #

    I just disable database and object cache based on the readmes caution for shared hosting.

  7. Frederick Townes
    Member
    Posted 3 years ago #

    Stay with the defaults for now and try to use the help tool on the minify settings tab to speed up your page renders for visitors. Then try browser caching also.

  8. kurdi
    Member
    Posted 2 years ago #

    I have been using w3tc for a long time, and have in fact recently had it professionally configured by W3EDGE. My site is http://www.freewaregenius.com

    However, I recently realized that I have the same issue described above: when entering comments, publishing post, or doing a variety of other things I get a "There were no suitable nodes to serve this request", and my site times out for a bit, before reviving again a couple of minutes later.

    This does not happen when I disable w3tc

    I would very much appreciate any insights on how this error can be averted.

Topic Closed

This topic has been closed to new replies.

About this Topic