WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Combine Only Before doesn't work (7 posts)

  1. SecureFreak
    Member
    Posted 2 years ago #

    I believe this setting is suppose to place the .js code that is combined at the end of the page before the closing <body> tag, correct?

    If so, checking this option does not work. I have tried it on two sites now. What should I be checking?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. SecureFreak
    Member
    Posted 2 years ago #

    So am I the only one experiencing this problem? If I make Minify mode: Auto and choose Combine only before </body> it still places the combined js file at the very top of the page.

    I need this to appear in the bottom because I need jQuery to load before all the javascript in the combined files.

  3. SecureFreak
    Member
    Posted 2 years ago #

  4. SecureFreak
    Member
    Posted 2 years ago #

    What is the function that adds the javascript and css right after the <head> tag?

  5. SecureFreak
    Member
    Posted 2 years ago #

    Found the solution: http://www.securefreak.com/moving-w3-total-cache-minify-auto-javascript-to-footer/

    It would be nice to make this an option in a future release.

  6. CrimsonLB42
    Member
    Posted 2 years ago #

    @SecureFreak Alas, you're not alone. I am having the same issue. I will take a look at your blog post. Thanks.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks I will address this in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic