WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
CloudFiles/CDN: New images throwing object already exists error (10 posts)

  1. Dagobah
    Member
    Posted 3 years ago #

    New install, and have everything loaded into the CDN. Existing files are working correctly, but new posts still have the local image path. Unsuccessful file transfer que is full of the new images, all with "Object already exists" error. Have this loaded on two blogs, and both are behaving the same.

    I see the "Force over-writing of existing files" option, but am not wanting to use this as a long term solution for CDN costs.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Some servers just don't do well with origin push CDNs. You can either try the development version or switch to an origin pull provider.

  3. Dagobah
    Member
    Posted 3 years ago #

    Are you implying CloudFiles might be the culprit, or the box we have our blogs on? If it's the blogs, it's a dedicated box at Rackspace, so we can customize as needed.

    Strangely, RS also recommends w3 total cache w/ cloud files, so I would assume they'd play nice together: http://www.rackspacecloud.com/blog/2010/09/02/optimize-your-wordpress-site-with-w3-total-cache/

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I wrote that post. The point is that origin pull is more reliable. There are lots of specific reasons why anomalies occur. So if you please try the development version and go from there.

  5. Dagobah
    Member
    Posted 3 years ago #

    Ha! Didn't even realize you had written it.

    I've installed the development version, and it seems to have fixed the above issue. Thanks for the help.

    Another CDN issue that I was having before on the is still persisting. Some files are throwing a "Unable to create object" error. I've tried re-uploading multiple times but doesn't help. The list is about 100 files all in the theme or wp-includes folders.

  6. Dagobah
    Member
    Posted 3 years ago #

    Bump

  7. ichilton
    Member
    Posted 3 years ago #

    Hi,

    The "Unable to create object" is a problem with W3TC trying to upload files to Cloud Files with a leading /

    I debugged it and raised a bug report a few weeks back detailing the problem and the line numbers in the code but never got a response to that or some other problems I raised.

    Shame really as it's a cool plugin :(

    Ian

  8. LifeAtTheCircus
    Member
    Posted 3 years ago #

    I too am having this problem (But I am using amazon cloudfront).

    Where/How do I get the development version?

  9. ichilton
    Member
    Posted 3 years ago #

  10. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble, please try the latest releases of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic