WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] CDN Test CloudFront Upload -> "Empty domain" (13 posts)

  1. TobiasSchulz
    Member
    Posted 3 years ago #

    I configured Amazon's CloudFront as a CDN. When I click on "Test CloudFront Upload", I get the message "Empty domain".

    I couldn't find any threads related to this problem.

    I had a quick look in the source code. It seems as if the XXX.cloudfront.net domain which I entered in the input field is not registered in the PHP object. Could be something totally different, too, though.

    Any ideas?

  2. dmiyares
    Member
    Posted 3 years ago #

    getting this error to since updating to 3.1 :(

  3. TobiasSchulz
    Member
    Posted 3 years ago #

    Nobody?

  4. Celinal
    Member
    Posted 3 years ago #

    I am encountering the same problem. It worked perfectly fine until recently, just discovered it now =/

  5. Craig Chamberlin
    Member
    Posted 3 years ago #

    Yes, this is kind of a funny issue, I got it resolved though.

    You paste your published file store URL without HTTP into the CNAME entry BELOW the .cloudfiles.rackspacecloud.com or CNAME: entry. In other words it will look something like this.

    | blank text box |.cloudfiles.rackspacecloud.com
    1. cxxxxxx.rx.xxx.rackcdn.com

    The URL is located on your RackspaceCloud Dashboard under Hosting > CloudFiles, select the store your CDN data is in and it's labeled CDN URL.

  6. TobiasSchulz
    Member
    Posted 3 years ago #

    Do you know if there is an additional URL for Amazon CloudFront, too, which I could try to enter in the CNET field? I had a look at the admin menu, but I couldn't find anything of the sort.

    I tried using

    | empty field | .cloudfront.net
    1. myaccount.cloudfront.net

    The result was that instead of "Empty domain" I got "Error: Unable to list buckets (S3::listBuckets(): [28] connect() timed out!)."

  7. Celinal
    Member
    Posted 3 years ago #

    Hmm..I am still getting the "empty domain".

  8. zkatkin
    Member
    Posted 3 years ago #

    Nudgymic nudge nudge... searching everywhere, can't find a fix.

  9. fretsch
    Member
    Posted 3 years ago #

    Having the same problem.. Anyone found a solution yet?

    Works with S3 but not cloudfront.

  10. fretsch
    Member
    Posted 3 years ago #

    I decided to do a CNAME. It works smooth, and looks much better.

  11. jlomaga
    Member
    Posted 3 years ago #

    Also had to do a CNAME in order to get S3 working again correctly. Even putting the long s3 address in the cname box didn't help, but as soon as I set-up a cname everything is back to normal.

  12. TobiasSchulz
    Member
    Posted 3 years ago #

    I can't use a CNAME and would be very grateful for a patch or workaround.

  13. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The most reliable way to do it is to allow W3TC to create the bucket and distribution, then wait a few minutes before activating CDN (check in the management console to make sure the distribution is enabled). Then use the W3TC test button to confirm.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic