WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] CDN: Path to custom file points to cdn, but file is not uploaded yet (5 posts)

  1. shortster
    Member
    Posted 3 years ago #

    I'm trying to deliver uploaded files, which are uploaded from my simple press forum, directly from my S3 cdn.

    What happens is this:

    • In cdn setting > custom file list: wp-content/forum-image-uploads/*
    • In the forum user chooses a file to upload
    • file gets uploaded to the path above
    • but the path to the image on the forum gets changed immediately to the cdn path, which leads to a broken img

    The auto-upload is set to 3600 so only then will the new files be uploaded to the cdn. Is it possible to only change the links to the new files when they are uploaded? Or is there another solution?

  2. blau
    Member
    Posted 3 years ago #

    W3TC auto uploads on the fly files added to the medialibrary, if your forum plugin adds files elsewhere, you could set a different auto-upload interval.

  3. shortster
    Member
    Posted 3 years ago #

    Thanks blau! That's good to know. I think I can point simple press to upload in a different folder, so I'll try to point it to the media library folder.

  4. shortster
    Member
    Posted 3 years ago #

    Just putting it in the upload folder does not seem to work. It really needs to be added to wordpress media library I guess.
    And setting the auto-upload interval to 1 sec does not feel like the right solution. Any other ideas?

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    And setting the auto-upload interval to 1 sec does not feel like the right solution.

    That's right it's not. For now, SimplePress needs to use the media library properly if you want everything to be fully automated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic