WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Causing problems with wp-cycle (8 posts)

  1. dpalme@dougpalme.com
    Member
    Posted 2 years ago #

    I installed the total cache plugin and got everything configured, including the addition of the CDN. Performance is great, bu the exception to that is, its causing problems with the wp-cycle plugin which works just fine when the total cache is turned off.

    In addition, IE8 shows errors when the total cache is activated.

    Any idea how to fix this problem?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Origami Penguin
    Member
    Posted 2 years ago #

    Hi I'm having the same problem, Total Cache has improved the speed of my site dramatically but the wp-cycle plugin has stopped working, a couple of image links have broken in other plugins and the cart button in woocomerce has disappeared.

    It can see it has added a 'display none' to the carts element property but I have no idea how to change it??

    Any help please?

  3. dpalme@dougpalme.com
    Member
    Posted 2 years ago #

    Bump, still waiting on a response to this one

  4. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Have you contacted the WP Cycle plugin author to ask how they can make it compatible with caching?

  5. Origami Penguin
    Member
    Posted 2 years ago #

    I used the cycle option in next gen gallery instead.

  6. dpalme@dougpalme.com
    Member
    Posted 2 years ago #

    Why are you assuming that its their plugin Fred? Their plugin works find with other caching programs, but breaks with yours...

  7. its causing problems with the wp-cycle plugin which works just fine when the total cache is turned off.

    Could you be more specific? What problems is it causing exactly.

    Are you getting javascript errors? wp-cycle is still using the wp_print_scripts hook to load its javascript. The correct hook to use with WordPress 3.3.1 is wp_enqueue_scripts.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Blame is completely irrelevant. This sounds like a minify issue and minify issues are not something i can fix. I simply integrate minfication seamlessly into a proper WPO workflow with W3TC, I cannot take responsibility for the code as it runs. If the issue is outside of minify, point that out dpalme@dougpalme.com and it will be addressed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic