WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Can't Properly Install Plugin, Multiple Errors (6 posts)

  1. goldnews.com
    Member
    Posted 3 years ago #

    The errors i receive are the following:

    You've enabled Browser Cache feature however the .htaccess file is not properly configured. Please run chmod 777 /home/.htaccess, then . To manually modify these settings use the following code: and .

    So i created a .htaccess file, changed the permissions to 777 in my ftp, and let the setting configuration fill in the code (i also tried it manually) and after this is done my webpage stops working entirely and i get this message:

    IISPassword
    The page cannot be displayed
    There is a problem with the page youare trying to reach and it cannot be displayed. It is most likely that configuration files for this url are corrupted.

    i can only solve this by replacing the .htacess file with a blank one or deleting it all together.

    in addition, i get this error message at the top:

    Unfortunately, PHP5 is required for full functionality of this plugin; incompatible features are automatically disabled. Please upgrade if possible.

    i'm not sure how i update this or acquire php5. Can someone please explain this to me?

    I'd really appreciate any help in solving the above problems and getting a caching system active for my website. I'd be happy to use a different plug in if it will work, but have already tried three different ones and each one has errors and problems on the install.

    thank you very much.

  2. Deknold
    Member
    Posted 3 years ago #

    Sounds like a conflict with IISPassword which generates .htaccess files to protect the folders. You can go into IISPassword options and tell it to use a different default access filename (e.g. .iisaccess). This is of course assuming you are in full control of your Windows Server.

  3. goldnews.com
    Member
    Posted 3 years ago #

    i have access i believe. I'm using ipower as a host and there is section called "IIS Administration Console".

    the first subsection is what i think you're talking about it and its called "default docs". i can't find a filename .iisaccess though.

    what is there includes the following examples:

    default.html
    default.asp
    index.html
    index.asp
    etc.

  4. Deknold
    Member
    Posted 3 years ago #

    Those are the default documents for the webserver.

    You'll want to find options for IISPassword, which is an ISAPI filter that is installed into IIS to do per-directory access control, and, following convention, it uses ".htaccess" where it defines the rules.

    I'm not familiar with your host, ipower, so I don't know how much you can configure. If you aren't directly controlling your own server, best to ask your host provider.

    If you were controlling your own server directly, the option is in:

    IIS Manager-> Web Sites (root folder) -> Right-click Properties -> on the IISPassword tab -> Access file name field

    Change it from the default .htaccess to any other name you want that doesn't conflict.

  5. goldnews.com
    Member
    Posted 3 years ago #

    Thanks for the response. I contacted the host provider and this is what they told me

    Unfortunately, .htaccess file will not work for your website. Since, your account is in Windows platform. You need to use httpd.ini file to enter any code.

    so how does this relate to the plugin? If I create the same code but put it in this file should it work then?

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    You will need to import the .htaccess rules for apache specified on the install tab of the plugin into your IIS configuration, for which there are tools/help wizards available.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic