WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Can't activate: fatal error involving permissions (25 posts)

  1. kristarella
    Member
    Posted 4 years ago #

    Hi,

    I'm getting essentially the same issues as described in the comments on the w3 Edge plugin page by Glenn, Dan and Francesco.

    I installed the plugin via the "Add new" dashboard plugins page, when I tried to activate it said it could not be activated due to a fatal error and to please chmod 777 wp-content/w3tc. At that time wp-content was 777 (owner me:group web) and wp-content/w3tc did not exist. So I tried creating wp-content/w3tc and chmod 777. Then when I tried to activate the plugin it came back with the same error and when I checked the directory wp-content/w3tc had been deleted.

    I tried this whole process a few times, deleting the plugin and following the installation instructions very carefully, same thing every time. w3tc is not created, but it asks me to chmod it. If I create it, it gets deleted upon attempted activation.

    Then I tried installing the plugin manually via FTP, same thing.

    I've asked on the forum with my host (NearlyFreeSpeech.net) because they do have a different server set up to more commonly used hosts (they run freeBSD), but I don't know if I'll get any insights. Other than that I'm using PHP 5.2.

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Thanks for your patience. It's doubtful that it's an OS issue although that is a good point. Let's try the basics one more time if you don't mind humoring me:

    1. Uninstall the plugin, make sure wp-content/w3-total-cache-config.php and wp-content/w3tc/ directories don't exist
    2. Make sure wp-content has 777 permissions
    3. Install & Activate plugin
  3. indigoprime
    Member
    Posted 4 years ago #

    I was also having this problem at Media Temple. I had to switch PHP safe mode to "off".

    It's just a check-box for me, but I think you can also just edit /etc/php.ini

    Nick.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    Thanks @indigoprime, I wonder if @kristarella is still having the issue?

  5. hixster
    Member
    Posted 4 years ago #

    I can confirm that switching PHP safe mode off worked for me as well.

    Thanks!

  6. Frederick Townes
    Member
    Posted 4 years ago #

    Ok great.

  7. webposer
    Member
    Posted 4 years ago #

    I dealt with the exact same thing. I'm on Media Temple DV; turned php safe mode and it finally worked. Thanks everyone.

  8. Frederick Townes
    Member
    Posted 4 years ago #

    Here's a helpful tutorial on that for anyone else on mediatemple.net hosting (although it's helpful for others as well): http://kb.mediatemple.net/questions/50/How+can+I+turn+off+safe_mode+on+an+(dv)+Dedicated-Virtual+Server+with+Plesk%3F

  9. kalchas
    Member
    Posted 4 years ago #

    Um, is it just me, or is anyone else bothered by granting 777 permissions on a web-accessible directory? Also, does it bother anyone else that this plugin requires very liberal permissions on php.ini? Are we just stuck with this (to me) pretty horrifically insecure situation when we're done, or can we revert the settings after the plugin is installed?

  10. Frederick Townes
    Member
    Posted 4 years ago #

    The permissions are not supposed to be left at 777. Have you read the installation instructions? Are you aware the plugin reminds you to restore the permissions if it detects chmod 777 ?

  11. kalchas
    Member
    Posted 4 years ago #

    My bad... I posted to early as I was working on this. Apologies, frederick.

  12. Frederick Townes
    Member
    Posted 4 years ago #

    Ok.

  13. kristarella
    Member
    Posted 4 years ago #

    I could have sworn I subscribed to this thread via RSS... I thought it had never received a reply!

    I tried the basics many times before giving up. I can give it another go I guess, but my server does have safe mode turned on and I can't turn it off (host doesn't allow it on shared server).

  14. Frederick Townes
    Member
    Posted 4 years ago #

    Ah, well I haven't finalized compatibility with safe mode yet, so I suppose W3TC is not a good fit yet.

  15. Elliott
    Member
    Posted 3 years ago #

    I have a dedicated server, run WordPress MU, safe mode is off, and I get "Plugin could not be activated because it triggered a fatal error." when trying to activate.

  16. Elliott
    Member
    Posted 3 years ago #

    Ugh. I had turned the wp-content back to 755. Should've stayed 777. It worked.

  17. Frederick Townes
    Member
    Posted 3 years ago #

    Ok great.

  18. passat
    Member
    Posted 3 years ago #

    I receive a fatal error too when trying to activate the plugin:
    Your store uploads folder is not available.
    That is definetely not true.

    Directories wp-content and uploads where chmodded 777
    Then I uploaded the plugin
    All other plugins were turned off
    Then tried to activate
    Then the error occurred.

    Safe Mode is Off

    Now what...?

  19. Frederick Townes
    Member
    Posted 3 years ago #

    If you contact me through my web site I will debug on your server.

  20. cihankusmez
    Member
    Posted 3 years ago #

    dear fredericktownes, i'm using shared server and safe mode is on. Can't i use w3 total cache ? i think you're the auther of plugin.

  21. Frederick Townes
    Member
    Posted 3 years ago #

    For now, no you cannot.

  22. Ambassador7
    Member
    Posted 3 years ago #

    Hmmm, I am having the same issue but cannot resolve it. It also will not let me deactivate the plugin...it brings me to a page with php. If I delete the files I get an error so I reinstalled.

    Would love to speed up my site, but not sure how to get around the permissions. Says it needs to be 777 but I am have changed it.

    I'd really appreciate any help.

  23. Frederick Townes
    Member
    Posted 3 years ago #

    If you send me an email through my site I'll try to help. You should be able to uninstall the plugin without issue nonetheless.

  24. alikasimoglu
    Member
    Posted 3 years ago #

    Hello Frederick,

    Im also using Media Temple Dedicated server. I want to use of your pluging but i cant activate it. When i click activate link then just white screen. nothing error messages or other things.

    php safe mode off for this domain. and all other think i have done true (777 chmod, deleted other cache plugins, pre-installed W3 Total Cache etc.).

    i dont know what is the problem. can you help me to install this plugin in my wp blog please? just say what i should do. i will be glad for this to you.

    Best regards, Anastasiya

  25. Frederick Townes
    Member
    Posted 3 years ago #

    Please try the development version of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic