WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Cannot set true 'do not cache' files/pages (7 posts)

  1. jtreminio
    Member
    Posted 4 years ago #

    Site is NSFW

    First off: this is an amazing plugin!

    Ok, now. I am using TDOMF forms. All it is is it lets unregistered users submit a new post without having to login or anything. They fill out this simple form on a specific page. It uses sessions to prevent spamming.

    The problem is that W3TC is cacheing the page and causing problems.

    The form is located on my page (warning: ADULT)

    http://www.cutiesr.us/submit

    The plugin files are located in

    wp-content/plugins/tdo-mini-forms

    And all files are php inside (the ones that do any processing).

    Everything works perfectly when I use the form, but since I'm logged in the cache is disabled for me. Under "Never Cache the Following Pages" I have:

    *tdomf*
    *submit*

    But apparently this isn't working. Any help with this would be appreciated, or the ability to completely turn off the cache for pages (but keep for frontpage/posts/search/etc).

    Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. jtreminio
    Member
    Posted 4 years ago #

    To clarify: this page is working for me because I am logged in and the page is not cache'ed for me.

    It is not working for unregistered, non-logged in users because W3TC is cache'ing the page, which I wish I could set it to not cache it!

  3. Frederick Townes
    Member
    Posted 4 years ago #

    Are you sure the form is not breaking due to HTML minification: inline JS/CSS minification or line break removal? When logged in you likely have HTML minfication disabled. Try to disable minfication first and let's go from there.

  4. jtreminio
    Member
    Posted 4 years ago #

    Hey there,

    I've disabled minification and still not working. Uploading a small image file is not recognized by the tdomf plugin.

    Thanks for the quick response time btw :)

  5. Frederick Townes
    Member
    Posted 4 years ago #

    Any chance I can get my hands on your settings? Likely there's a cookie that W3TC should be set to ignore that it is not and I would be happy to add it to the default configuration once I know what it is.

  6. masterbassie
    Member
    Posted 4 years ago #

    any solution to this problem with tdomf? i'm experiencing the same problem with caching. thanks in advance

  7. Frederick Townes
    Member
    Posted 4 years ago #

    For @masterbassie, this issue was resolved in: http://wordpress.org/support/topic/336587?replies=4

Topic Closed

This topic has been closed to new replies.

About this Topic