WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Cannot get out of preview mode (21 posts)

  1. Rhand
    Member
    Posted 4 years ago #

    Installed W3 Total cache. Tried to deploy, but it kept on telling me:

    Preview mode could not be disabled. Please run chmod 777 /path/to/wp-content/w3-total-cache-config-preview.php to make the configuration file write-able, then try again.

    I decided to download the file and reload it so it would be no longer CHOWN Apache Apache, but part of the group my user is in. So that I could actually CHMOD it. I chmodded it 777. That did not help. The warning just kept on popping up. I guess I will have to try a complete re-installation now?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Probably, normally follow the installation instructions allows the plugin to do everything for you. It would be easier to start over.

  3. automaton
    Member
    Posted 3 years ago #

    I'm having the same problem, and I'm guessing it's a conflict with Super Cache. I think I've completely removed all traces of Super Cache, but I might be missing something.
    Weird thing is, I think the page cache *is* working, but minify definitely isn't.
    Would a reinstall solve that? I'm about to find out.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did it?

  5. automaton
    Member
    Posted 3 years ago #

    Yup, solved. But now it keeps saying .htaccess is write protected while it isn't. That's only relevant for enhanced page caching so not a big issue in our case. But nevertheless weird, as I'm 100% sure I've set the file permissions correctly.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    PHP can't write to the file so the notification is shown. If there's a bug somehow, happy to look, you can use the bug submission form from the support tab of the plugin.

  7. tinygiantstudios
    Member
    Posted 3 years ago #

    I'm having the same problem on http://www.feintandmargin.com,

    I'm stuck in preview mode despite permission on the preview file being set to 777...

    Any ideas what I could do?

    And yep, I double-checked those permissions: both config and config-preview have 777 permissions.

    Thanks Mr. Townes in advance :)

  8. Leon Stafford
    Member
    Posted 3 years ago #

    same deal here. on WP 3.01

    I tried first installing via SSH then removed and tried via FTP upload.

    Same deal both time. the /path/to/wp-content/w3-total-cache-config-preview.php file shows user/group as both apache (on MediaTemple (dv) hosting). After it failed both times, I tried changing to same user/group as other plugins' default owners but no luck.

    nb. I have memcached installed OK, other than that is standard setup

  9. Leon Stafford
    Member
    Posted 3 years ago #

    ok, seemed to be permissions related to wp-content folder. deleted the config-preview file, 777'd wp-content, rebuillt settings file and all seems good.

  10. marky_uk
    Member
    Posted 3 years ago #

    I've installed this on two WAMP (Windows Server 2003) servers and have the same problem on both servers.

    Any ideas how to fix on there?

    Thanks in advance :-)

    Marky_UK

  11. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry I don't use WAMP, but it's a permissions issue on wp-content/ as @leonstafford discovered.

  12. marky_uk
    Member
    Posted 3 years ago #

    Hi Frederick,

    Thanks for the reply. I've taken ownership of the wp-content/ folder as Administrator and it's made no difference.

    Anyone else out there in TV land got this working on Windows?

    Marky_UK

  13. automaton
    Member
    Posted 3 years ago #

    @leonstafford Thanks for the tip, I'll give it a try. Unfortunately, I can't just delete my .htaccess and have W3TC recreate it.

  14. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    It's not about taking ownership, it's about making sure that your web server (PHP) can change files.

  15. jaykimball
    Member
    Posted 3 years ago #

    Hi Fredrick,
    I just installed your plugin, and generally all is well, I have the following warning at the top"

    "Preview mode is active: Changed settings will not take effect until you deploy or disable preview mode. Preview any changed settings (without deploying), or make additional changes."

    What is preview mode? Should I deploy or disable? Do I need permissions to be at 777 before doing that? For which folders?

    Thanks, jay

  16. jaykimball
    Member
    Posted 3 years ago #

    I See the following issues when running compatibility check:

    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed

    How do I get those installed? I am running WP in a shared host at GoDaddy.

    Thanks!

  17. jaykimball
    Member
    Posted 3 years ago #

    After activating, I went to ismyblogworking.com and got the following results:

    "Your blog seems slow. It took 3.34 seconds to generate the page."

    Any idea why things are slow? My website is 8020vision.com

    Also, it said that GZIP was not working (see message below). Is that an issue? How do I correct?

    Feature Supported?
    RSS yes
    RDF no
    Atom no
    Page Gzip no
    Feed Gzip no
    Page 304 no
    Feed 304 yes
    robots.txt yes

  18. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    At godaddy, you cannot install any server side software. Disable preview mode if you wish, as the name suggests it allows you to click the preview button and review setting changes before deploying them so your visitors can see the effects of them. If preview mode is disabled, changes take affect immediately or when the cache is emptied. Shared hosting is going to be arbitrarily slow because there are no dedicated resources for your site. Caching reduces the work that the server has to do, but again, you still do not have resources dedicated to serving your site. So what you can do is use minify and possibly add a content delivery network, but you still will have arbitrarily slow responses from godaddy for your HTML, which is what browsers request first when browsing sites as you know.

    To be clear, I just went to: http://ismyblogworking.com/8020vision.com and saw:

    The boring technical details:

    Web hosting: godaddy.com
    Server support link: godaddy.com
    Server hostname: p3slh051.shr.phx3.secureserver.net
    80 ms page generation time
    240 ms page fetch time
    98 KB/sec effective transfer speed
    261 KB/sec burst download speed
    80 ms feed generation time
    110 ms feed fetch time
    28 KB/sec effective feed transfer speed
    0 KB/sec burst feed download speed
    Page size (uncompressed): 80,444 bytes
    Download size (compressed): 23,977 bytes
    Bandwidth saved by compression: 70.2%
    Content ratio: 54.0%
    Blog If-Modified-Since response: 304
    Feed If-None-Match response: 304
    RSD URL: 8020vision.com
    WLW manifest URL: 8020vision.com
    WordPress theme: Thesis
    Generator: wordpress.org 3.0.1
    WordPress version: 3.0.1

    Feature Supported?
    RSS yes
    RDF no
    Atom no
    Page Gzip yes
    Feed Gzip yes
    Page 304 yes
    Feed 304 yes
    robots.txt yes

  19. Rhand
    Member
    Posted 3 years ago #

    For me it was just a server permission issue in the end and all is well now.

  20. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Ok great.

  21. skaye
    Member
    Posted 3 years ago #

    I just deleted the preview file, emptied the cache and everything was good to go.

    I didn't need to change the permission on the wp-content directory or anything. Certainly not wise to have the publicly writeable.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic