WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Cannot change permissions in 'w3tc' folder (7 posts)

  1. Lapple
    Member
    Posted 4 years ago #

    Hello, thanks for this amazing plugin.

    Recently I have updated my hosting from PHP4 to PHP5 support in order to enable minify function. But now I get this error message:

    'The "Rewrite URL Structure" feature, requires rewrite rules be present. Please run chmod 777 /wp-content/w3tc/min/.htaccess, then try again. To manually modify your server configuration for minify append the following code:'

    When I run this command in Total Commander (binary mode), server replies that I lack permission for that. I also cannot change chmod for w3-total-cache-config.php.

    If you need some extra information, please specify and I will be glad to send it to you.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 4 years ago #

    I can't trouble shoot why you don't have permissions for that. But you might try backing up your settings file (in wp-content/) and then deactivating and reactivating the plugin after deleting db.php, advanced-cache.php and w3tc/ from wp-content/.

  3. Lapple
    Member
    Posted 4 years ago #

    Yes, I did that, but I could not completely remove the 'w3tc' folder. When I reactivate the plugin there is an error message saying something like 'Fatal error occured while activating the plugin. Unable to write into the configuration file', which is w3-total-cache-config.php.

    To add some information, current chmod for each directory described is 644 and cannot be changed either via Total Commander or via CPanel's built-in file manager.

  4. wrbm
    Member
    Posted 4 years ago #

    Hi There,

    I am stuck and badly need help.

    The site is hosted on IIS6.0 and uses ISAPI_rewrite for URL rewriting. On disabling the 'Rewrite URL Structure' option under Minify Settings, I get the error

    "The 'Rewrite URL Structure' feature, requires rewrite rules be present. Please run chmod 777 F:\websites\Live\50Best/wp-content/w3tc/min/.htaccess, then . To manually modify your server configuration for minify append the following code: .....(followed by the .htaccess rules/code). All permissiosn aregiven for the folder and the same rules are present in the .htaccess file. When its disabled the site is abnormally slow or does not open.

    If the option is checked then the site is slower than before applying minfication.

    Can you please advice on how to go about this.

  5. Frederick Townes
    Member
    Posted 4 years ago #

    Unfortunately, I do not have any tips for IIS that I can recommend for general use. I will work on this more in the future or you can request professional support via email to allow me time to focus on it.

  6. remotay
    Member
    Posted 4 years ago #

    does it show the group's owner in ftp as 000 or 999? If so, it means your user doesn't own the files. There's a php file somewhere you can upload and execute to fix the issue. I had the same thing happen to me with a few nextgen galleries.

  7. Frederick Townes
    Member
    Posted 4 years ago #

    Romotay makes a useful comment. On windows especially it's helpful if the owner and group for files and directories is identical to what the web server uses when it creates them.

Topic Closed

This topic has been closed to new replies.

About this Topic