WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] Caching: enabled Status: not cached (15 posts)

  1. Cristian
    Member
    Posted 4 years ago #

    Hi,

    Does it mean the page was not cached? If so, what is the reason for that page not being cached?

    I tried to refresh the different pages a few times to give W3TC the chance to cache the pages but it did not make any difference.
    See below my debug info.

    Thank you for your help in advance.

    <!-- W3 Total Cache: Page cache debug info:
    Engine: apc
    Key: w3tc_b9b190e90e262264345359434ba61dd5_page_535460f534322d34a4253c9e31c40269_gzip
    Caching: enabled
    Status: not cached
    Creation Time: 0.325s
    Header info:
    X-Powered-By: PHP/5.2.5
    Pragma: public
    Expires: Wed, 24 Mar 2010 02:50:49 GMT
    Last-Modified: Wed, 24 Mar 2010 02:47:49 GMT
    Cache-Control: max-age=180, public, must-revalidate, proxy-revalidate
    Vary: Accept-Encoding, Cookie
    Etag: 856a4e87edc4eb6dd0c29cea9604f50d
    Content-Encoding: gzip
    -->

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Yes, it means the page was not cached. Did you try to open the same page in various browsers? Did you empty your browser cache between tests?

  3. Cristian
    Member
    Posted 4 years ago #

    Hi Frederick,

    yes W3TC cached the page again after I emptied the browser cache which makes sense.

    Thank you

  4. Frederick Townes
    Member
    Posted 4 years ago #

    You're welcome.

  5. Joost
    Member
    Posted 4 years ago #

    Hi,

    After some playing around I still am not able to get the status of pages to cached. It keeps saying Status: not cached.

    However, the timestamp of the debug info stays the same.

    I have installed memcached and APC on the server.

    What am I missing?

  6. Joost
    Member
    Posted 4 years ago #

    Ah, sorry. Got it to work. Was looking at front page, and that page is not cached by default.

    Why is that?

  7. Frederick Townes
    Member
    Posted 4 years ago #

    The home page is cached by default. Did you deselect the option?

  8. Joost
    Member
    Posted 4 years ago #

    Nope. On the page cache settings page, index.php was included in the "Never cache the following pages" setting. I think that was the problem, because when I removed it, it cached the front page directly.

  9. Frederick Townes
    Member
    Posted 4 years ago #

    So your problem is resolved jberculo?

  10. Joost
    Member
    Posted 4 years ago #

    Probably, as it says that the page is cached now.

    On the other hand, the index.php was probably added to "Never cache the following pages" for a good reason.

    So I am wondering, should the page be there, and can my removal of it have unforseen consequences?

  11. Frederick Townes
    Member
    Posted 4 years ago #

    You should keep the defaults unless you have a good reason.

  12. Joost
    Member
    Posted 4 years ago #

    Yes well, that is what I am asking myself. Do I have a good reason to do so?

    Basically: does the index.php belong in the "Never cache the following pages" setting?

  13. Frederick Townes
    Member
    Posted 4 years ago #

    Yes.

  14. Joost
    Member
    Posted 4 years ago #

    Thanks. Then I will put it back there and look further into the problem :-)

  15. Frederick Townes
    Member
    Posted 4 years ago #

    Ok.

Topic Closed

This topic has been closed to new replies.

About this Topic