WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Cache for GoogleBot? (10 posts)

  1. rhythmdoctor
    Member
    Posted 3 years ago #

    Frederick, Is there a way to make it such that Google gets cached versions of the pages as it appears (within webmaster tools -> labs -> site performance) that my sight is being measured and given page load times more than 2-3 times that of what Pingdom and other tools show. Thanks in advance.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Klark0
    Member
    Posted 3 years ago #

    pingdom doesn't seem to load everything. see what webpagetest.org reports.

  3. efikim
    Member
    Posted 3 years ago #

    I don't think that the labs site performance data makes any use of Googlebot (it wouldn't make sense, as Googlebot just loads the HTML page data, and not images, javascript or CSS, I think)

    I think its data comes from real users using the Google toolbar

  4. rhythmdoctor
    Member
    Posted 3 years ago #

    yea, tried your suggestion KLARKO, and still massive variance in what it shows and what Google shows - google showing at least 2-3 times the time to load.

    As for Efikim - They definitely count the JS, CSS, etc... - it is kinda a new thing in webmaster tools as it is now a new factor for search rankings.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The webmaster tools performance is determined by google toolbar traffic. By default W3TC is returning cached pages to everyone, however the overall total load time of the page is what google is using to determine your score so you will need to fully tune your site.

  6. rhythmdoctor
    Member
    Posted 3 years ago #

    Thanks Frederick. Ill email you about it. What would be a comparable tool that I could see what it is actually taking to load my site? If I look at it using Google page speed, or pingdom, It seems to be loading much faster than the times they state. Much appreciated.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

  8. rhythmdoctor
    Member
    Posted 3 years ago #

    Yeah, weird - it also shows it loading at around 5-6 sec. vs. Google's claim that it takes 10-13 seconds... Oh well, not going to worry about it for now :)

  9. Klark0
    Member
    Posted 3 years ago #

    This same thing bothered for me for while, but i gave up worrying about it.
    Serps have never been higher, and adsense is up.

  10. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Google is reporting on users using the Google toolbar, which is lots of different users on lots of different connection speeds. So you have more optimization to do.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic