WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] BuddyPress not being sent from CDN (6 posts)

  1. Mark Waters
    Member
    Posted 4 years ago #

    I am using BuddyPress 1.2.3 and WordPress 2.9.2 and am seeing files still being sent from the local webserver rather than the CDN even though I have included this in the Custom File List :-
    wp-content/blogs.dir/1/*

    Here is an example from the log :-

    GET /blogs.dir/1/files/group-avatars/3/8cca061fff8be6b398a5047171ab47fa-bpthumb.jpg

    Any suggestions ?

  2. Frederick Townes
    Member
    Posted 4 years ago #

    You're using the latest release?

  3. Mark Waters
    Member
    Posted 4 years ago #

    yes , using the development version of w3 total cache as its released.

    I have enabled cdn debug mode and saved the html page at :-

    http://dl.dropbox.com/u/283947/w3.total.cache.blogs.weloveit.info.cdn.debug.html

    You can see the .css and .js files are coming from the cdn ok.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    WP MU handles URIs in a strange way and removes wp-content/ from the URI (according to tests). So this is not a bug in W3TC as it stands, however I'll try a workaround. This likely doesn't exist in WP 3.0.

  5. Mark Waters
    Member
    Posted 4 years ago #

    I will keep up-to-date with the development releases and tell you how it improves with WordPress-MU.

    For now I have uploaded the largest files to the 'CDN' manually and setup redirects and its all working well.

    The issue has made me learn about Apache redirection and alias functions which I have now put to good use for our Gallery too.

    Thanks for the great plugin and ideas!

  6. Frederick Townes
    Member
    Posted 4 years ago #

    Ok. I'd also be appreciative if you'd WP 3.0 beta (or trunk) and see how things go for you there.

Topic Closed

This topic has been closed to new replies.

About this Topic