WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Browser Caching Problem [Please Help] (11 posts)

  1. mike6436
    Member
    Posted 2 years ago #

    Hey there,

    I've been getting the message below every once in awhile. Is there a way to keep browser caching enabled? I keep pressing the auto install button, however, after 12-24 hours the message will return.

    The Message: "Browser caching is not active. To enable it, add the following rules into the server configuration file (/home/XXXX/public_html/XXXX.org/.htaccess) of the site . Or if permission allow this can be done automatically, by clicking here:"

    Thanks guys, love the plugin!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. robnalexpress
    Member
    Posted 2 years ago #

    I wonder if the auto-install is actually adding the code. Next time you get that message, try doing it manually: Open the .htaccess file for editing (code edit) through cpanel/file manager or ftp, delete the existing w3tc browser cache rules and paste the new code in its place and save. If that doesn't work, then something is changing the code.

    Is yours a single site or multisite installation? If it's multisite, your browser cache settings may not be the same on all sites (they need to be) and that could explain it.

  3. mike6436
    Member
    Posted 2 years ago #

    I have a single site installation. I'll see about adding the code manually. Is the Browser Caching code listed some where within the settings page? Thanks for your help.

  4. robnalexpress
    Member
    Posted 2 years ago #

    When you get that message there should be a link/button that says "show code" or something like that. You can copy it from there.

  5. tgeorge
    Member
    Posted 2 years ago #

    In the "Install" tab of W3TC, you can see the contents of your .htaccess file.

  6. mike6436
    Member
    Posted 2 years ago #

    Thanks for the help guys. I noticed that the auto-installer is working correctly- the code does populate in my .htaccess file when I click the install button. However, every time I add/modify a page W3TC wants to reinstall the browser cache. Is that normal? Thanks again for the help!

  7. robnalexpress
    Member
    Posted 2 years ago #

    No, not normal. Something isn't right.

  8. thelaw
    Member
    Posted 2 years ago #

    I have the exact same problem. I have the code in the htaccess file. It's in there. But I keep getting that same error message appearing:

    Browser caching is not active. To enable it, add the following rules into the server configuration file (/.htaccess) of the site . Or if permission allow this can be done automatically, by clicking here:

    I see it in the htaccess file in the root. Not sure where else this is supposed to be, if anywhere.

  9. cyonite
    Member
    Posted 2 years ago #

    If this is still an issue could you please submit a bug submission form from the Support page in the plugin?

  10. thelaw
    Member
    Posted 2 years ago #

    I sent in a report but never heard back. I had to disable the plugin because I had the above problem and also gzip errors on several occasions, especially using some plugins. I'm glad to work through the problems with someone if they are willing to help me resetup the plugin and test it. I've had several extremely experienced linux admins and LAMP specialists work with me and they could not solve the issues.

  11. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    For now I recommend disabling http compression on the browser cache settings tab until a remedy is found.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic