WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Breaks Contact Form 7 Ajax (Old 0.8 Version Works) (20 posts)

  1. war59312
    Member
    Posted 4 years ago #

    Hi,

    Sadly w3-total-cache version 0.8.5.2 breaks Contact Form 7: http://contactform7.com/

    None of the ajax in Contact Form 7 works after installing w3-total-cache. This is with the latest version of w3-total-cache.

    Even if I disable all the options in w3-total-cache, the contact page ajax is broken.

    If I disable the w3-total-cache plugin itself then no more problem.

    This bug was introduced in w3-total-cache version 0.8.5

    I know this because I have reinstalled w3-total-cache version 0.8 which works fine with Contact Form 7.

    Please fix this bug. I really would love to use the latest w3-total-cache version.

    Thanks,

    Will

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Pascal Dreissen
    Member
    Posted 4 years ago #

    Works here w/a problem icm. with 8.5.2. Are you using minify, disable it, clear cache and try again, probably your minify settings need some finetuning.

  3. Kristina
    Member
    Posted 4 years ago #

    I too am having this problem. I removed anything related to Contact Form 7 from the minification settings with the same result. It broke the Ajax!

  4. Kristina
    Member
    Posted 4 years ago #

    deleted duplicate post

  5. Frederick Townes
    Member
    Posted 4 years ago #

    Do you have database caching enabled?

  6. war59312
    Member
    Posted 4 years ago #

    Nothing is enabled and I get the problem. All options are disabled and same problem.

    Hope that is clear. ;)

  7. Frederick Townes
    Member
    Posted 4 years ago #

    Can you post your settings so I can duplicate?

  8. war59312
    Member
    Posted 4 years ago #

    Default settings. As in simply installing the plug-in causes the issue.

  9. Frederick Townes
    Member
    Posted 4 years ago #

    Can someone with this issue submit a bug submission report from the support tab of the plugin please?

  10. war59312
    Member
    Posted 4 years ago #

    Your support request has been successfully sent.

    Thanks!

  11. andiepu
    Member
    Posted 4 years ago #

    any news about this? txs

  12. war59312
    Member
    Posted 4 years ago #

    Fred is still working on it with me.

    Thanks again Fred for your help.

  13. Frederick Townes
    Member
    Posted 4 years ago #

    Turns out this is actually a known issue fixed in the next release.

  14. war59312
    Member
    Posted 4 years ago #

    So when is that next release?

    Still broke even after upgrade to WP3.

    Workground is to disable "Debug Mode for Page Cache".

  15. war59312
    Member
    Posted 4 years ago #

    Development Version:

    http://wordpress.org/extend/plugins/w3-total-cache/download/

    Fixed. :) Thanks a ton!!

  16. Frederick Townes
    Member
    Posted 4 years ago #

    Great

  17. jainsy
    Member
    Posted 3 years ago #

    Have just installed the development version but still no luck.

    What specific contact form 7 settings do i need to have configured within w3? It works fine when I disable JS in minify.

  18. jainsy
    Member
    Posted 3 years ago #

    anyone?

  19. Frederick Townes
    Member
    Posted 3 years ago #

    It works fine when I disable JS in minify.

    Try removing the JS you have minified for cf7. Not all script scan be minified as is.

  20. balwinder singh
    Member
    Posted 3 years ago #

    Dear Frederick Townes , thanks for wonderful plugin, but i m facing a big problem i m also using w3 total cache plugin for my site http://www.theindiapost.com but i m not able to write a new post when ever i try it gives 500 error my host is go daddy . even i m not able to disable w3 total cache plugin.

    regards

Topic Closed

This topic has been closed to new replies.

About this Topic