WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Blank Homepage (9 posts)

  1. escalatoraccidnt
    Member
    Posted 3 years ago #

    Hello,

    First time using W3 Total Cache. Once activated the homepage loads an empty white page.

    Internal pages seem to load fine aside from being very slow.

    This is my site drugrehab411.com

    I'll leave the plugin active for now. Here is an internal page that is working:

    http://www.drugrehab411.com/state/alaska/

    The only strange things I've noticed is that I can only select disk caching even though on on a VPS and not a shared server. Also, here is my comparability check:

    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected
    WordPress Resources
    .../wp-content: Write-able
    .../.htaccess Write-able
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

    I tried disabling everything one by one. So I currently only have page caching enabled...

    Thanks in advance for any help.

  2. escalatoraccidnt
    Member
    Posted 3 years ago #

    Just wanted to update that for right now I'm deactivating the plugin to troubleshoot other things.

  3. escalatoraccidnt
    Member
    Posted 3 years ago #

    ** ANOTHER UPDATE **

    I've fixed the home page issue. I had to increase my php memory limit to 128M and the time limit to 60.

    So far that's getting the site moving along. However I'm still struggling with load times.

    Sometimes a page will pop quickly, hover other times it takes the home page up to 20 - 30 seconds to load...

    Trying to get the following options fixed with my server so that I can get better caching I'm guessing...

    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed

  4. escalatoraccidnt
    Member
    Posted 3 years ago #

    ** UPDATE **

    So I'm still suffering from a slow site...

    Here are the errors I'm having with W3

    PHP Timezone: Not set
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Mimetype
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected

    My server says that everything but memcache was installed... Why can't I detect them?

  5. escalatoraccidnt
    Member
    Posted 3 years ago #

    bump bump bump it up...

    Waited a few days. Anyone out there have any ideas?

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    What are your settings? You should be using disk enhanced for page caching, which is the default.

  7. escalatoraccidnt
    Member
    Posted 3 years ago #

    Hello Frederick,

    I left the default settings, which helped only slightly...

    I thought the options below disk enhanced would be better/faster than disk enhanced. Since I have a vps I was under the impression that I should be using one of the Opcode options.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    The default settings are not going to be enough. They're intended to allow uninitiated users to being using the plugin without lots of surprises. Check out the instructions on the plugin install page again.

  9. Lester Chan
    Member
    Posted 3 years ago #

    Hmm, I am getting the same exact issue on CPanel VPS.

    If I disable W3 but leave the plugin activated and set WP_CACHE to FALSE in wp-config.php, it works.

    If I disable W3 but leave the plugin activated and set WP_CACHE to TRUE in wp-config.php, it does not work.

    If I enable W3 (just the CDN (NetDNA) option) and set WP_CACHE to true or false in wp-config.php, it does not work as well.

    But setting the memory_limit and max_exuction_time in PHP to 256M and 60 fixed it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic