WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Amazon Cloudfront CDN not working. (10 posts)

  1. azn137
    Member
    Posted 2 years ago #

    Please help. I've set W3TC to use Amazon CF, but it doesn't seem to be using it at all. What am I doing wrong? If you need any more info, please let me know.

    My blog is at http://tambnguyen.com/

    Here's the info: http://www.webpagetest.org/result/120723_E2_NHV/1/details/

    Here's the screen shot of my setting: http://i.imgur.com/vqcd3.jpg?1

    Thank you very much in advance

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. azn137
    Member
    Posted 2 years ago #

    I've tried reinstalling the plugin, no help :(

  3. azn137
    Member
    Posted 2 years ago #

    I've reverted it back to w3-total-cache.0.9.2.3 with no help.

  4. azn137
    Member
    Posted 2 years ago #

    Fixed. Apparently, I put some useragent in the bypass list for CDN, and it practically wiped out everybody.

  5. urbanite
    Member
    Posted 2 years ago #

    Could you please elaborate how you'd fixed it? I'm trying to configure W3TC for CDN but am finding that nothing is being served by the CDN. Had contacted MaxCDN customer support and the lady has confirmed that "w3 total-cache and CDN is already well-implemented" but I see nothing being served by CDN when I log on Pingdom.

  6. azn137
    Member
    Posted 2 years ago #

    First, make sure your CDN is up and running. While in panic mode, I messed around with mine and inadvertently changed a setting, which caused it to be in "In progress" status instead of "Ready".

    You can do a test by going into your wp-admin >> Performance >> CDN >> Configuration >> Test.

    Once the test passes, go back to Performance >> General settings >> Debug >> tick the "Content Delivery Network" box >> save.

    When I turned mine on, I looked at the source code on the frontend (you have to do this on a different browser where you're not logged in), and saw that CDN was rejected by user agent.

    Go to Performance >> CDN >> "Rejected user agents:" >> make sure it doesn't block anything funky. I wiped that list out and it started working for me.

    I remember putting Google crawler's user agent onto that list, but I'm not sure what else I had on there that made it not work. Again, while in panic mode, I cleared the list and things were back to the way they were.

    Hope that helps.

  7. urbanite
    Member
    Posted 2 years ago #

    Thank you! Have nothing on the rejected user agent list but the debugging is a very good idea- will try that.

    The CDN provider is telling me it's because of Cloud Flare, which is strange given the write-ups on combining Cloud Flare and a CDN. I think it could be the way I'd configured caching from Cloud Flare...

  8. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Did you get to the bottom of the issue?

  9. urbanite
    Member
    Posted 1 year ago #

    Hi Frederick,

    The problem seemed to be the separate Gzip plugin. Turning that off seemed to solve the problem. Didn't like having the Gzip plugin turned off though so will only stick with Cloud Flare for the moment.

  10. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Aha, glad you sorted it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic