WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Amazon CDN - Test fail, but works as CDN (12 posts)

  1. thebizguy
    Member
    Posted 4 years ago #

    I have W3 installed and working with Amazon CDN configured.

    When I use the button test cloudfront upload, i receive the following error. Test failed. Error: Unable to list distributions.

    However I have manually load the content on CDN and it delivers correctly.

    what is the issue with the test failure and how do I resolve?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Please submit a bug submission request from the support tab of the plugin, there are no obvious causes for this error.

  3. cosmictap
    Member
    Posted 4 years ago #

    I've received the same error in trying to configure cloudfront CDN option. I'll submit, but if anyone has solved this I'd appreciate the insight.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    Is cURL for PHP installed?

  5. Sam_a
    Member
    Posted 3 years ago #

    I'm getting the "Unable to list distributions" error also.

    It's a IIS-6 server with curl installed.

    The error message for the request was "could not connect to host". Could be a problem making SSL requests on a Windows server? See the comments — http://php.net/manual/en/ref.curl.php

  6. Frederick Townes
    Member
    Posted 3 years ago #

    @Sam_a unfortunately, I don't officially support IIS, although I'm aware of successful installations. If you submit a bug submission form I will see if I can find any obvious issues.

  7. Sam_a
    Member
    Posted 3 years ago #

    I haven't been able to test it, but some Googling suggests setting CURLOPT_SSL_VERIFYHOST or CURLOPT_SSL_VERIFYPEER or both to false might work on IIS.

  8. Frederick Townes
    Member
    Posted 3 years ago #

    Did you apply those changes yourself? Any luck?

  9. Sam_a
    Member
    Posted 3 years ago #

    I did get a successful connection after setting CURLOPT_SSL_VERIFYPEER to false, but I have a hunch that updating curl's certificates might be the proper fix.

    So I set CURLOPT_VERBOSE => true and first tried CURLOPT_SSL_VERIFYPEER => true:

    * About to connect() to www.google.com port 443 (#0)
    *   Trying 74.125.67.103... * connected
    * Connected to www.google.com (74.125.67.103) port 443 (#0)
    * SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    * Closing connection #0

    And then I tried CURLOPT_SSL_VERIFYPEER => false

    * About to connect() to www.google.com port 443 (#0)
    *   Trying 74.125.67.103... * connected
    * Connected to www.google.com (74.125.67.103) port 443 (#0)
    * SSL connection using RC4-SHA
    * Server certificate:
    […]
    * SSL certificate verify result: unable to get local issuer certificate (20), continuing anyway.
  10. Frederick Townes
    Member
    Posted 3 years ago #

    There's an option to ignore certificates with curl btw.

  11. invertedonion
    Member
    Posted 3 years ago #

    I had the same problem using php-fpm & nginx. turned out i hadn't installed the PHP openssl extension so W3TC was reverting to http:// for cloudfront, which doesn't accept connections.

  12. Frederick Townes
    Member
    Posted 3 years ago #

    I see.

Topic Closed

This topic has been closed to new replies.

About this Topic