WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] "Add Expires Headers" and "Compress components" (4 posts)

  1. ronblaisdell
    Member
    Posted 3 years ago #

    Things have been working great! I have reduced the load time for my site by 70% -- however -- I am stuck on some reports that I am getting from YSlow.

    In the "Browser Cache," I have ensured that I have "Set expires header", "Set cache control header", and "Enable HTTP (gzip) compression" all checked. And in each of the three sub-sections, I have the "Cache Control policy" set to "cache with max-age," and the "Expires header lifetime" set to 604800 for Media, CSS and JS files.

    But I am still seeing reports indicating that things are being delivered without expirations -- and that the system is not delivering gzipped versions (and yes, they do exist).

    Any thoughts on what I should check next?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Why did you change the browser cache default settings? 31536000 is the expires value YSlow is looking for.

  3. ronblaisdell
    Member
    Posted 3 years ago #

    Ok ... I reset the "Expires header lifetime" to 31536000, cleared all the cached files, and accessed the site with a browser not logged in as Admin.

    However, YSlow still shows that we have files without expiration dates (and a grade of F).

  4. ronblaisdell
    Member
    Posted 3 years ago #

    By deleting items from my CDN and then re-loading them via the appropriate CDN section, I have been able to take care of the "expires lifetime header" once I reset to the default 31536000.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic