WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] 500 Internal Server Error (40 posts)

  1. wavesoftech
    Member
    Posted 4 years ago #

    Frederick first I love your work and thanks for what you do for the community. I have been attempting to install the latest release of W3TC with wordpress 3. In doing so after activation I receive the:

    You've selected disk caching with enhanced mode however the .htaccess file is not properly configured. Please run chmod 777 /home/waves8/public_html/.htaccess, then . To manually modify your server configuration for enhanced mode append the following code:

    I have changed the .htaccess and attempted the retry. You code gets inserted into the .htaccess then I get:

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@wavesoftech.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.wavesoftech.com Port 80

    The site is then totally down and I have to remove the W3TC code from the .htaccess file. Any assistance would be appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 4 years ago #

    You can switch to disk basic for page caching, which requires no .htaccess directives meanwhile and submit a bug submission report from the support tab of the plugin.

  3. Terence
    Member
    Posted 4 years ago #

    Frederick, I have exactly the same problem. With disk basic caching it works, but with enhanced it crashes the site with a 500 internal server error. I will send you a support config and bug report asap.

    Got a question. Where can I find "Cache Control policy" explained and how to choose/select the appropriate option?

    By the way, I much prefer the new interface in this version. Much more logical, and I like the "Performance" touch... 8^)

  4. fitnessguide67
    Member
    Posted 4 years ago #

    exactly the same issue with all my servers.. :(

  5. yabate
    Member
    Posted 4 years ago #

    Hello Frederic, me again.
    After removing the previous version, and now installing the latest, with basic page caching works everything OK, but with enhanced, i got again internal 500.

  6. anteck
    Member
    Posted 4 years ago #

    Yup, i totally deleted the plugin, renabled, and 500 Error.

    It's broken!

  7. Scott Winterroth
    Member
    Posted 4 years ago #

    Yep, same problem here.

  8. Frederick Townes
    Member
    Posted 4 years ago #

    All, you all still have old .htaccess rules for disk enhanced and they could not be removed for you automatically upon deactivation. If you edit out those rules and then deactivate / reactivate the plugin.

  9. robertstaddon
    Member
    Posted 4 years ago #

    I had 500 Internal Server Errors when I upgraded to the latest version and copied the new suggested rules into my .htaccess file. I figured out that the RewriteCond %{HTTP_USER_AGENT} line was not properly escaped.

    In my case, this happened because the automatic upgrade/install had not automatically replaced the old db.php, advanced-cache.php, and object-cache.php files in the wp-content directory.

    After replacing these files with the new versions, the suggested code to paste into my .htaccess file suddenly had the proper escape characters. I copied this code into my .htaccess file and it solved my 500 Internal Server Errors.

  10. Frederick Townes
    Member
    Posted 4 years ago #

    @robertstaddon thanks for explaining. I may try to push an update that tries to handle more cases.

  11. KimJCastleberry
    Member
    Posted 4 years ago #

    Same basic situation here - but was upgrading from the dev release - that confirms what @robertstaddon saw. Its not really the new plugin thats broke, its something in the upgrade path. I was unable to get it working until I removed the old copies of the 3 files directly in wp-content. Server error log during the 500 read:
    [Thu Jul 22 19:39:09 2010] [alert] [client 67.43.117.214] /home/username/public_html/.htaccess: RewriteCond: bad flag delimiters Sounds like you've got it under control though.

    Thanks Frederick!
    Kimberly

  12. ezzal
    Member
    Posted 4 years ago #

    I also had the problem , but solved.
    Read here : http://wordpress.org/support/topic/427676

  13. Frederick Townes
    Member
    Posted 4 years ago #

    There's another update coming today that better handles update issues. It's really best to do the following rather than changing the new user groups, which were painstakingly created for your benefit:

    1. Remove W3 Total Cache rules from your .htaccess file in document root
    2. Delete from wp-content/
      db.php
      object-cache.php
      advanced-cache.php
      w3-total-cache-config.php (if you want)
    3. Then rename or delete wp-content/plugins/w3-total-cache/ if you still have any issues accessing WP Admin and reinstall once you can login again (and rename it back if you have)
  14. KimJCastleberry
    Member
    Posted 3 years ago #

    I did an upgrade that went to 500, and then I logged into the host. I did steps 2 & 3, but didn't think to do 1, Once two and three were done, it didnt seem to have any issues with the htaccess rules. No clue why. Just tossing that out there.

  15. Frederick Townes
    Member
    Posted 3 years ago #

    Different servers and W3TC version combinations will behave differently. This software is quite complex, unlike the majority of plugins.

  16. ezzal
    Member
    Posted 3 years ago #

    I agree on that. Its a great plugin anyways !

  17. Frederick Townes
    Member
    Posted 3 years ago #

    Thanks.

  18. anteck
    Member
    Posted 3 years ago #

    Thanks Frederick for addressing this issue for us.. muchly appreciated!

  19. Frederick Townes
    Member
    Posted 3 years ago #

    No problem, I would love to avoid these issues if I could, but there are limitations unfortunately.

  20. globe_trotter
    Member
    Posted 3 years ago #

    3 weeks to the day and STILL the same problem! Crashed my site..."thanks".
    You seriously need to address this because the problem is persisting. Going back to the cache plugins I was using with ZERO problems.

  21. mkassian
    Member
    Posted 3 years ago #

    I am new to W3 Total Cache. I wanted to use it because of its great reviews. But on activation of the plug-in, I got the 500 error. I had to manually remove all the files and clean out the htaccess to get things working again. Is there an end to this 500 bug in sight? W3 sounds like a super cache solution, and I'd love to use it.

  22. Frederick Townes
    Member
    Posted 3 years ago #

    There will be no end if users don't allow me to investigate the origin of their issue. You can contact me through my web site if you would like to constructively contribute.

    Over the past year there are lots of reasons for lots of errors, it's not as if the same issue has existed indefinitely.

    At the moment, the issue is caused by users who have move their web site and the WordPress database has the WRONG value for the path to the uploads directory. So you can go to the misc' section in WP Admin and change the uploads value to anything other than it's current setting and save. Then restore the previous value and save the settings again. Then try to follow the installation instructions again for W3 Total Cache. This issue was difficult to find as it doesn't affect everyone and there's no error message or anything in error logs when users experience it.

    A workaround for that is coming in the next release.

  23. Matt Oettinger
    Member
    Posted 3 years ago #

    I just installed it and as soon as I clicked "activate", my entire site started getting 500 internal server error. Too bad since I have this plugin on another site and love it. Hope the next release with a fix comes soon.

  24. Frederick Townes
    Member
    Posted 3 years ago #

    @blueicreate, that comment doesn't help me make sure there will be a fix. Did you compare your .htaccess files on your sites to see what the differences were? Did you check your error log? Could you actually help please?

  25. chipcopeland
    Member
    Posted 3 years ago #

    I had this problem but found a work around that some of you might want to try.

    I built a site locally then switched to a hosted environment. If you have FTP access to your site then try downloading the plugin to your computer, unpack it, then upload it to your plugins folder. I didn't have to touch a line of code after that.

    While this solution worked for me it still might not with other users.

    BTW, Frederick; you guys rock on the WordPress Podcast. I learn so much just listening. Keep up the good work.

    [UPDATE]- Ok, so it didn't work for me. Don't try this. It's all about learning new things right guys and gals? Sorry for screwing anybody up.

  26. dmgphotography
    Member
    Posted 3 years ago #

    Hi Frederick. I also had the "activate causing 500 Internal Errors" issue. It took me several minutes of panicked frenzy to figure out that the .htaccess file was probably at the root of the issue. I would have loved to give you a comparison, but I was so flustered with a failed site that I just restored the file from a backup. Only afterwards did I wonder what was going on.

    I would have provided an error log excerpt but, for me, there were no errors being generated in a place where I could see them. My hosting service gives me an access log and a CGI error log, but nothing was being put into that CGI error log. While I'm sure there were errors being generated I didn't see them (other than on the browser) and I'm not sure I can see them.

    Now that I know what's going on, I'm willing to reinstall the plugin (over the weekend when things are quiet) and attempt to figure out what is happening. If there is any additional information you need (apache version, etc.) that would be of use please let me know.

  27. thomas50
    Member
    Posted 3 years ago #

    Hi There -

    Can somebody walk me through a manual removal of the files to restore my blog after the "500 error"? I thought I removed all the files associated with W3 and I restored my .htaccess file and yet my blog is still down. I am more than a little freaked out right now....

    Thanks!

  28. Frederick Townes
    Member
    Posted 3 years ago #

    If you've restored your .htaccess file to the state before the installation, then this post is what you need: http://wordpress.org/support/topic/plugin-w3-total-cache-500-internal-server-error?replies=27#post-1612692

  29. crewparty
    Member
    Posted 3 years ago #

    Hi Fredrick, love your plugin!

    I have installed your plug-n on over 6 of my sites all of which are Hosted with the same host company. However, with my latest site (also with the same Host) the minute i Activated the Plug-In the site disappear into Error 500. Now, we know already that it has to do with the .htaccess re-writes, however after spending the day with my Host Company support they couldn’t figure it out.

    For some reason once the Plugin is activated it generates the following code which creates the Error 500:

    <FilesMatch "\.(?i:css|js)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(?i:html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(?i:asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|swf|tar|tif|tiff|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.1.1"
    </IfModule>
    </FilesMatch>
    
    Full source of .htaccess file which causes 500 error message you may see with name .htaccess_ in your estheticclinique.co.uk domain.
    Also let me inform you that FilesMatch directive works perfectly at your server. You may check it using the following example:
    
    <FilesMatch "\.(htm|html|css|js|php)$">
    AddDefaultCharset UTF-8
    DefaultLanguage en-US
    </FilesMatch>

    `
    It would be great to get some direction as to how do i go about sorting this out.

    many thanks.

    D.

  30. Frederick Townes
    Member
    Posted 3 years ago #

    If you go to miscellaneous settings and change the uploads path to any other setting, save the settings, then revert the setting to the previous value and save the settings again you should be able to activate. If not, let me know.

Topic Closed

This topic has been closed to new replies.

About this Topic