WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
500 Internal Server Error (15 posts)

  1. cwanca
    Member
    Posted 2 years ago #

    My .htacces file was getting updated and causing 500 Internal Server error, even without changing any W3 Total Cache settings. I was originally using page caching enchanced (disk enhanced), but changed it to disk basic as I read it would no longer use the .htaccess. However, I am still getting the same issue, though not as frequent. I suspect when it is updating .htaccess for browser caching.

    -a shared hosting account
    -WordPress 3.2.1
    -w3 total cache 0.9.2.4
    -page caching enabled (disk basic)
    -browser caching enabled
    -miscellaneous settings left to defaults (checked: verify rewrite rules, enable news dashboard widget, Enable Google Page Speed dashboard widget without an Page Speed API Key.)

    I have not used other caching plugins before.

    I read on a forum that someone that had done an automatic upgrade experienced a problem like this. I had originally install w3tc 0.9.2.3 and auto upgraded to 0.9.2.4, but then deactivated and removed plugin completely and reinstalled 0.9.2.4. Still getting the same issue.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Franck Scipion
    Member
    Posted 2 years ago #

    Same problem here. It's redundant and annoying

    ┬┐Any solution?

  3. I suspect when it is updating .htaccess for browser caching.

    If you have access to your server's error_log then if should be able to identify what is tossing those 500 errors. All the .htaccess additions are supposed to be wrapped in <IfModule...> to prevent those kind of errors, so there maybe something in the existing .htaccess file that is confusing W3TC.

    That should help you sort it out. If you don't have that access, ask your host for assistance.

  4. cwanca
    Member
    Posted 2 years ago #

    There doesn't seem to bee any helpful info in my error_log, which I read may be a result of an invalid directive in an .htaccess.

    My .htaccess only includes # BEGIN/END W3TC Browser Cache and # BEGIN/END WordPres. Below are my .htaccess contents:

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_setenvif.c>
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    </IfModule>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    <IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE text/css application/x-javascript text/x-component text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon
    </IfModule>
    </IfModule>
    <FilesMatch "\.(css|js|htc|CSS|JS|HTC)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.2.4"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|HTML|HTM|RTF|RTX|SVG|SVGZ|TXT|XSD|XSL|XML)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.2.4"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip|ASF|ASX|WAX|WMV|WMX|AVI|BMP|CLASS|DIVX|DOC|DOCX|EOT|EXE|GIF|GZ|GZIP|ICO|JPG|JPEG|JPE|MDB|MID|MIDI|MOV|QT|MP3|M4A|MP4|M4V|MPEG|MPG|MPE|MPP|OTF|ODB|ODC|ODF|ODG|ODP|ODS|ODT|OGG|PDF|PNG|POT|PPS|PPT|PPTX|RA|RAM|SVG|SVGZ|SWF|TAR|TIF|TIFF|TTF|TTC|WAV|WMA|WRI|XLA|XLS|XLSX|XLT|XLW|ZIP)$">
    FileETag None
    <IfModule mod_headers.c>
    Header set X-Powered-By "W3 Total Cache/0.9.2.4"
    </IfModule>
    </FilesMatch>
    # END W3TC Browser Cache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  5. robustos
    Member
    Posted 2 years ago #

    Hi,

    We have almost same environment and same issue. It has become a nightmare since WordPress is now generating .htaccess file each 60 seconds all the time with same data.. but what make it worst is that from time to time it generate a malformed .htaccess file making our site offline with a pretty "error 500" and with a bunch of errors on logs.

    What we have as a workaround right now to me make it continuously working is having .htaccess file with chmod 444 (not writable but readable).

    Is interesting this problem since we have others sites with same setup with no issues and working perfectly.

    I really hope it could be fixed on the code since has been impossible to us determine what is causing this.

    --Rodrigo

  6. wampdog29
    Member
    Posted 2 years ago #

    I believe I have come across this as well, although I may need another day to see if it really WAS the W3 Total Cache plugin. I have been receiving 500 internal server errors with my error logs showing "premature end script headers . index" or whatever.

    So, I thought I got rid of the errors by deactivating Cubepoints plugins and aaaall day long I was fine until about 1 AM EST. Tried deactivating W3 Total Cache and so far, the site has been running fine. We'll see....

  7. adrian7
    Member
    Posted 2 years ago #

    It seems to be a bug in W3 Total Cahe for .htaccess code generation.
    First any W3 total cache rules should be located AFTER # END WordPress.

    Then check to see if there are some "BEGIN W3TC" or "END W3TC" strings left, those should always bedin with a #.

  8. customdigitalhome
    Member
    Posted 2 years ago #

    Going to jump in here because I think my issue may be related.
    I am a really green WP user here so if possible show some kindness :)

    I installed / activated the W3 Total Cache plugin last month but got some page loading errors and could not access admin, etc. I had to follow some suggestions to manually remove the plugin from my site - and I suspect that this is also related. I think these errors stemmed from my use of a "coming soon" plugin and the W3TC plugin had trouble with that... not positive though.

    My site in most respects seems OK - until I touch the pages or posts section - then I immediately get "No input file specified" errors. Accessing plugins, appearance, my home page are all good. Only happens when I access posts / pages. Once I get the error NOTHING works... I get "No input file specified" on every link in my admin.

    I found that if I wait (at least a minute) I can then get back to all pages. Of course if I touch pages / posts I trip the process all over again.

    Checking my .htaccess file just I see many references to the W3TC plugin. In fact, it looks like the entire "W3TC Page Cache core" is still there and active! (e.g. none of these lines are commented out)

    With the plugin removed at this point what should I do? Should I manually just try to clean up the .htaccess file?

    Thanks for any guidance on this.

  9. customdigitalhome
    Member
    Posted 2 years ago #

    Update:
    As a test, I edited out all of the W3TC entries in my .htaccess file but found that I also had to edit the my wp-config.php file.
    Seems to be OK now.

    A follow-up question would be to go back to original W3TC issues - is it likely that my problem with caching was due to the "coming soon" plugin? I'd like to eventually get benefits of caching when the site goes live but not if it is so fragile that I risk making the site unstable.

  10. gezginrocker
    Member
    Posted 2 years ago #

    I am having this problem when I enable Browser Cache & auto install the necessary code to htaccess. Then I immediately get 500 Internal Server Error. If I remove Browser Cache code from htaccess, it returns back to normal.

    And it doesn't matter if the code is located after # END WordPress, as suggested before.

  11. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble everyone. Can people submit a bug submission form from the support tab of the plugin so I can understand the issues better.

  12. cwanca
    Member
    Posted 2 years ago #

    Frederick,
    I don't see a support tab. Is this the correct place to look for the tab:
    http://wordpress.org/extend/plugins/w3-total-cache/

    Cortney

  13. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    It's in the plugin itself.

  14. jordan@triplethreat.org
    Member
    Posted 2 years ago #

    Just updated to the latest version of WordPress, and noticed the update made it run a lot slower on the front end. So I went into the W 3 Total Cache plugin to check the settings. The moment I ran the auto-install portion of w3tc (pink box on the top), I got a 500 Internal Server Error. Front end is 500 internal server error, and so is the backend WP dashboard.

    Did some forum searching, and the creator of the plugin suggested the following in this thread (which is now closed):

    There's another update coming today that better handles update issues. It's really best to do the following rather than changing the new user groups, which were painstakingly created for your benefit:

    (1)Remove W3 Total Cache rules from your .htaccess file in document root
    (2) Delete from wp-content/
    db.php
    object-cache.php
    advanced-cache.php
    w3-total-cache-config.php (if you want)
    (3) Then rename or delete wp-content/plugins/w3-total-cache/ if you still have any issues accessing WP Admin and reinstall once you can login again (and rename it back if you have)

    1. I made sure the public_html folder was chmod 777 and replaced the .htaccess file to the default:
    contents: # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    2. I deleted the db.php, object-cache.php, advanced-cache.php and w3-total-cache-config.php files from my FTP server.

    3. I deleted the w3-total-cache folder from wp-content

    So I did all of the above, but still I'm getting 500 internal server error. Can't bring up my website or login to the backend dashboard. Not sure what the best route is to get my site back up and running.

    Any clues where to go with this?

  15. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Those are the correct steps. The error you actually see in your error log, probably holds the key.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic