WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] 404 on every page when disabled (18 posts)

  1. flipz
    Member
    Posted 4 years ago #

    Hey all. I am using WordPress 2.9.2 and W3TC 0.9.1.1 on my site at http://geekfor.me. I've been very happy with it after switching from WP super cache several months ago.

    Today I disabled W3TC to do something unrelated by deselecting "Deselect this option to disable all caching functionality." A short while later I noticed that while my main page would load no matter what comment/page/post I clicked on I would get a 404 error.

    After backtracking my steps I realized it probably started after disabling W3TC. I went and deactivated it on the plugins screen too and that made no difference. So I turned it back on, cleared the cache, and instantly everything started working again. No more 404's.

    What could have caused this, and how can I disable W3TC without breaking my site? Thanks for any help.

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Are there errors in your error log? There should normally be no issues with disabling all caching engines while the plugin was enabled. It seems that your .htaccess file had some issue after you saved your W3TC setting changes? If you were using disk enhanced page caching I'd like to investigate and see how to duplicate.

  3. Shivanand The Designer
    Member
    Posted 3 years ago #

    Same here. Seems like it messed up the (wordpress) .htaccess rules in the blog root. Had to append the mod_rewrite ON line.

  4. Frederick Townes
    Member
    Posted 3 years ago #

    It would be nice to see your original .htaccess files to understand what's happening here.

  5. Shivanand The Designer
    Member
    Posted 3 years ago #

    And this happened whenever I turned off Page Cache Disk Enhanced Or switched to PAge Cache Basic.
    The correct one:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    The disfigured one:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Pls understand I'm not blaming your plugin. It's a great plugin and I'm myself an author of GPL software. Just that maybe there was a glitch. May be a lil verbosity or a backing up of original htaccess will help.

  6. Frederick Townes
    Member
    Posted 3 years ago #

    I don't feel as though I'm being blamed. What I don't understand is why you think that W3TC modified directives inside of WordPress comments there. It doesn't do that.

  7. Frederick Townes
    Member
    Posted 3 years ago #

    Can someone please be so kind submit a bug submission form from the support tab of the plugin, so I can attempt to duplicate?

  8. shirls
    Member
    Posted 3 years ago #

    Hi there,

    I have the similar problem with W3 plugin this morning.

    I read some very good reviews about W3, so i decided to delete super cache plugin, and switched to W3 this morning. However, for first 10 mins or so was working well, but rating of google page speed dropped instead of improved. So, I tried to configure it more, to enable more caching like the database. But then, I couldn't view my blog at all while logged in (dashboard has no problem though) So, I deactivated the plugin and checked if other things gone wrong. And suddenly my blog would not load at all, if it loaded, only loaded half a page, and all links were broken. I reactivated the plugin, but not as lucky, my blog still broken.

    I don't know what have gone wrong, and quite worried coz I have no ideas how to fix it. So, I deleted the plugin, interestingly, my blog still completely broken. So, I just asked my host to restore the site. Waiting for their technician to look into it.

    So sorry for the above long comment, not to complain or anything. Just like to know if it is due to a bug in the plugin.

    Since there are many good reviews of W3, I still would like to try it, but very worry the same thing will happen again.

    Your reassurance or attendance to the above issues is much appreciated. Thanks a lot.

    cheers
    Shirls

  9. Frederick Townes
    Member
    Posted 3 years ago #

    @shirls you can contact me through my site and I will look at your situation.

  10. shirls
    Member
    Posted 3 years ago #

    Hi Federick,

    Thanks for your reply. I am going to contact u now through your site. Thanks in advance for your help.

  11. Frederick Townes
    Member
    Posted 3 years ago #

    No problem.

  12. peeld
    Member
    Posted 3 years ago #

    I installed W3 Total Cache just now, things seemed fine, til I went to look at the site...ack! My blog pages wouldn't load, nor any others but the home page! Got a 404 error on all other pages.

    Deactivated and deleted W3 Total Cache, flushed permalinks, and got *some* of the pages back, the blog, but it looks like any custom post types are...GONE. This is a big deal, please help ASAP :(

  13. Frederick Townes
    Member
    Posted 3 years ago #

    Sorry, are you saying that W3TC removed files from your server? Can you restore a backup?

  14. peeld
    Member
    Posted 3 years ago #

    I uninstalled the plugin, reinstalled, cleared all caches and it seems to work fine, although I won't be trying for a CDN or anything...

    Daisy

  15. Frederick Townes
    Member
    Posted 3 years ago #

    Ok, great.

  16. donna03281
    Member
    Posted 3 years ago #

    Yes, I'm a newbie and trying to speed up performance of site so I installed and activated W3 Total Cache. It slowed down administration panel quite considerably!!!

    Unfortunately, I have not really found "step by step" instructions for downloading for quasi beginners . . . I get this message in the W3 total cache setting screen.

    /home/content/44/7621244/html/wordpress/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /home/content/44/7621244/html/wordpress/wp-content.

    Can anybody tell me exactly what I'm supposed to do with this message - step by step . . . where am I supposed to find this file?

    Sorry for the beginner's ignorance, but really want to understand.

    Thank you.

  17. Shivanand The Designer
    Member
    Posted 3 years ago #

    Unsub.

  18. donna03281
    Member
    Posted 3 years ago #

    Unsub??????????? What does that mean? The only thing I relate "unsub" to is the show "Criminal Minds". lol Is that supposed to refer to something?

Topic Closed

This topic has been closed to new replies.

About this Topic