WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] (3 posts)

  1. newman6066
    Member
    Posted 3 years ago #

    Hello,

    Since installing W3 Total Cache our site has generally been much quicker, with exception of the homepage which is now taking nearly 10 seconds to load. We have set it up with CDN from Amazon CloudFront, and use a lot of images on the homepage, so we expected to see some benefit more or less straight away - instead the homepage is now slower than before.

    My question is, could it have something to do with the following entries in the "Never cache the following pages" section on the "Page Cache Settings" page:

    wp-.*\.php
    index\.php

    The two entries appeared as default when we installed the plugin, so I have been relucant to remove them without checking first...

    Would removing them do the trick?

  2. bobmorris60
    Member
    Posted 3 years ago #

    I have those settings on my blog and the home page is cached.

    If you View Source on the home page, you should see something like this at the bottom

    !-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

    If it's there, the page is being cached, then your problem is something else, like configuration with Amazon

  3. Frederick Townes
    Member
    Posted 3 years ago #

    Would removing them do the trick?

    No.

    If caching is running correctly, and you minified your JS + CSS, then you need to look at reducing the file size of images or other objects on the page or even reducing the number of posts on the home page to make the page faster.

Topic Closed

This topic has been closed to new replies.

About this Topic