WordPress.org

Ready to get started?Download WordPress

Forums

[PLUGIN: W3 Total Cache 0.9.1.1] Does not work with domain mapping (8 posts)

  1. benjamin3264
    Member
    Posted 4 years ago #

    Using WP 3.0, Domain Mapping 0.5.2 and W3 Total Cache 0.9.1.1

    Caching works for sub-domains, e.g. foo.domain.com.

    Caching does NOT work for domains, e.g. foo.com.

    I am a programmer and can fix this if provided with a brief overview of what could possibly be causing this and/or where to look in the codebase.

    Thank you.

  2. Frederick Townes
    Member
    Posted 4 years ago #

    I would need to know more about how things are set up to be able to assist. Support for the domain mapping has not been fully implemented because everyone who's run that plugin has been unwilling to allow me to debug myself.

  3. epschmidt
    Member
    Posted 4 years ago #

    Has there been any update on this? I am also running WP 3.0.1 Multisite with the Domain Mapping plugin. Running W3 Total Cache causes all domains to lead to the main site.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    I would like to look at your site if possible to investigate. A bug submission form from the support tab of the plugin would be helpful.

  5. TexInWien
    Member
    Posted 4 years ago #

    I'm running the Domain Mapping plugin on WP 3.01 and would be willing to allow you to debug on one of my development or test installations.

    I'll bet this is due to relying on the domain name for the cache folder name.

    I'll let you debug on my development server if you'd like.

    Kurt

  6. TexInWien
    Member
    Posted 4 years ago #

    By the way, I can't confirm epschmidt's report, but what I do see is that the domain rewriting for mirrors was working with subdomains but is not working with tld's.

    On our dev server we have a URL structure like this:
    [projid].dev.projects.xioup.com

    I installed W3 Total Cache on that server and rewriting worked fine for all sites - media URLs were changed to http://ourmirror.com/path/to/file/.

    As soon as I changed these sites use a tld as their primary domain, the URL-rewriting stopped working.

    Kurt

  7. TexInWien
    Member
    Posted 4 years ago #

    I submitted a bug request from the support tab.

  8. Frederick Townes
    Member
    Posted 3 years ago #

    Turns out some of the forthcoming changes to the plugin's structure will resolve this issue in the next release.

Topic Closed

This topic has been closed to new replies.

About this Topic